VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2] 3 4

Author Topic: [BREAKTHROUGH!][Read 1st Post] I need to get 16-bit to work! [i810][DRI][Crash]  (Read 12913 times)

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: I think my graphics card should work faster.
« Reply #15 on: June 09, 2008, 02:46:04 pm »

Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #16 on: June 09, 2008, 03:05:39 pm »

/var/log/Xorg.0.log Warnings
Code: [Select]
(WW) intel(0): DRI is disabled because it runs only at 16-bit depth.

(WW) intel(0): xf86AllocateGARTMemory: allocation of 1024 pages failed

(WW) intel(0): xf86BindGARTMemory: binding of gart memory with key 1
at offset 0x4000000 failed (Invalid argument)

(WW) intel(0): xf86BindGARTMemory: binding of gart memory with key 2
at offset 0x4000000 failed (Invalid argument)

(WW) intel(0): Direct rendering disabled

(WW) intel(0): Option "UseEdidFreqs" is not used

(WW) Option "XkbModel" requires an string value

(WW) Option "XkbVariant" requires an string value
Logged

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #17 on: June 09, 2008, 03:38:04 pm »

I may have found the answer! And no need to recompile the kernel! Edit the lilo file and add

Code: [Select]
vga=normal under append= list and then in the terminal run lilo, and then reboot. Might work, let's see! Cross your fingers you!
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: I think my graphics card should work faster.
« Reply #18 on: June 09, 2008, 04:02:14 pm »

Forgive me as I'm only skimming but your depth is currently 24 bit according to your xorg.conf you posted:
Quote
DefaultDepth 24
Just change that to 16 if you're needing 16 bit.
Or just tell me to jump in a lake if I've misunderstood. :D
Logged

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #19 on: June 09, 2008, 04:44:57 pm »

16 bit crashes on load. I want 16 bit. I need 16 bit. 16 bit is being mean and crashing =(

Someone said it  may have been that the framebuffer is using the 16-bit, I added vga=normal to the lilo file. (Not after append =, it wont work, but as it's own option) And I think it doesn't load framebuffer. But 16 bit still crashes. Whyyyy!

For example: startx makes the screen glitch with colorful colors and stripes and random nonsense. It basically freezes.
« Last Edit: June 09, 2008, 04:47:11 pm by ultrasonicsite »
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: I think my graphics card should work faster.
« Reply #20 on: June 09, 2008, 05:26:52 pm »

I may have found the answer! And no need to recompile the kernel! Edit the lilo file and add

Code: [Select]
vga=normal under append= list and then in the terminal run lilo, and then reboot. Might work, let's see! Cross your fingers you!
Which lilo file are you talking about? /etc/lilo.conf?
if so, under which 'append =' should I add that line?
did it work for you?
Thanks in advance.
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #21 on: June 09, 2008, 05:47:10 pm »

Yes that lilo file, but for me it didn't help. If you want to try, don't add it to append, just make a new line and type vga=normal. The newest version of lilo wont let you add that to append = "blahblahblah"
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: I think my graphics card should work faster.
« Reply #22 on: June 09, 2008, 05:58:14 pm »

Yes that lilo file, but for me it didn't help. If you want to try, don't add it to append, just make a new line and type vga=normal. The newest version of lilo wont let you add that to append = "blahblahblah"

did you run "lilo -v" as root after modify your lilo.conf?
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: I think my graphics card should work faster.
« Reply #23 on: June 09, 2008, 06:00:02 pm »

I failed to mention in the post above - I have 3 'append=' in my /etc/lilo.conf. under which should I add it?
Also I have this line commented out at the begging of /etc/lilo.conf
and also a question: what this line do?
thanks a lot. 
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: I think my graphics card should work faster.
« Reply #24 on: June 09, 2008, 07:44:02 pm »

Try changing Driver "i810" to Driver "vesa" in /etc/X11/xorg.conf and see what happens.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: I think my graphics card should work faster.
« Reply #25 on: June 09, 2008, 09:37:55 pm »

I did a bit of googling and it seems like nobody with my good old Neomagic MagicGraph 256AV [NM2200] have DRI.
I saw a littlebit about recompiling kernel. Seems like that's pretty hard and time consuming.
So here comes the question:
Could it be managed by semy-noob like me?
And if so, will the result worth it?
Thanks a lot.
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #26 on: June 14, 2008, 11:54:13 am »

I'll try what you guys suggested, I hope vesa works!

Compiling isn't too hard as long as you have a good speedy computer, and have all the requirements to compile. And know what parameters to pass.
Logged

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #27 on: June 14, 2008, 12:05:12 pm »

16 bit vesa didn't work either, what was displayed was something like when you're watching tv, but the signal isn't strong enough so its just a scrambled mess flying around.

24 bit vesa is just a black screen.
Logged

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #28 on: June 14, 2008, 12:37:14 pm »

According to http://dri.freedesktop.org/wiki/DriTroubleshooting , there's a chance my card isn't getting 'probed', whatever that means, I'll have to see how to fix this.
Logged

ultrasonicsite

  • Packager
  • Vectorite
  • ****
  • Posts: 107
Re: I think my graphics card should work faster.
« Reply #29 on: June 14, 2008, 12:39:20 pm »

I'll download the latest DRM CVS sources, and go from there.
Logged
Pages: 1 [2] 3 4