VectorLinux
September 01, 2014, 06:07:01 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Nics keep switching despite rules in /etc/udev/rules.d/network-devices  (Read 2669 times)
RagingGoblin
Member
*
Posts: 3


« on: June 09, 2008, 01:10:27 am »

Hello,
With VL 5.9 I have the switching problem. One NIC is a BroadCom 4318, a wireless pcmcia card, the other a onboard NIC I never use. The BIOS does not give me the possibility to switch of this one. I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. The only solution I see is to write a script that parses the output of iwconfig and sets a symlink to eth0 or eth1 and use this. I do not have the knowledge about bash to do this, so I will have to learn this. Anyone with another idea?
« Last Edit: June 09, 2008, 01:22:44 am by RagingGoblin » Logged
rbistolfi
Packager
Vectorian
****
Posts: 2282


« Reply #1 on: June 09, 2008, 06:04:17 am »

Please take a look at this: http://www.vectorlinux.com/forum2/index.php?topic=979.0
Let us know if that works for you.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
RagingGoblin
Member
*
Posts: 3


« Reply #2 on: June 09, 2008, 06:20:10 am »

I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. T

No this did not work
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #3 on: June 09, 2008, 06:37:37 am »

IMO the easiest way to do this would be to copy the script /sbin/VLwifi and take out the user prompts and replace them with your essid and such then have it run at boot
Logged
RagingGoblin
Member
*
Posts: 3


« Reply #4 on: June 19, 2008, 04:58:01 am »

Solved, Setting the rules in /etc/udev/rules.d/network-devices.rules behaves strange:

Setting only the onboard card to eth0 -> switching
Setting the onboard to eth0, the pcmcia to eth1 -> switching
Setting only the pcmcia card to eth1 -> no switching !!

 Huh

Anyway problem solved
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!