VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [SOLVED] Vertical Lines on LCD  (Read 3145 times)

Hacker John

  • Member
  • *
  • Posts: 21
[SOLVED] Vertical Lines on LCD
« on: May 22, 2008, 10:17:10 am »

I'm getting vertical lines on and LCD screen with VL 5.9.

I used VLXconf to probe the screen, which correctly identified the make and model.  There are an awful lot of lines specifiying resolution.  A typical entry in Xorg.conf is

ModeLine "1280x1024"   135.00 1280 1296  1440 1688 1024 1025 1028 1066 +hsync +vsync

Do i need to choose one of these lines and comment out the rest?  Or are the vertical lines caused by something else?

Any help gratefully received.
« Last Edit: May 23, 2008, 09:27:22 am by Hacker John »
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Vertical Lines on LCD
« Reply #1 on: May 22, 2008, 02:17:55 pm »

You should not be messing with the config file unless you know what you are doing...
Those lines are generated by the config utility
the module will only use the one line (or section of the line) that it needs to display the graphics.

You could tell us what kind of graphic chip you've got on your box, and tell us the result of
Code: [Select]
cat /etc/X11/xorg.conf | grep DriverThat will help pinpoint the problem..

As a suggestion, and I'm just shooting in the dark here, these are some things you can try

  • try using the vesa driver
  • try changing the color depth
  • try using a different screen resolution

Let us know if any of these do anything at all.

Stay tuned ;)

Hacker John

  • Member
  • *
  • Posts: 21
Re: Vertical Lines on LCD
« Reply #2 on: May 23, 2008, 09:26:45 am »

Thanks for the reply Moe.  I messed about with VASM until I got to 1280 X 1024 in 24 - bit colour.  I edited the Hsync to 30-55 and voila!  A perfect screen.  Thanks for the pointers - got there in the end.
Logged

Hacker John

  • Member
  • *
  • Posts: 21
Re: [SOLVED] Vertical Lines on LCD
« Reply #3 on: May 23, 2008, 09:29:41 am »

My graphics controller is an Intel 82815 Chipset (VGA compatible) for anyone following this.  My screen is a Hannspree LM02.
Logged

budulay

  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: [SOLVED] Vertical Lines on LCD
« Reply #4 on: May 23, 2008, 10:52:29 am »

I had the same issue.
Searched frum and find few advises. Than changed Sync to 30-55. It helped at first, but then all the story went again.
But I managed it:
I just punched my LCD in the back and holded it like that. Every time Lines arrived I did that and after some time they dissapeared. Sounds like a barbaric solution, but it worked...
Someimes they apeears again, but not too often. Usulay when computer gets hot from staing on for a long time. Then I use my violent method, and everything goes fine.
« Last Edit: May 26, 2008, 03:58:21 pm by budulay »
Logged
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!