VectorLinux
December 21, 2014, 09:34:01 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: need latest version of glib2 and gtk to get some new gtk software (+ gimp 2.5.1)  (Read 4250 times)
blurymind
Packager
Vectorian
****
Posts: 1082



« on: June 17, 2008, 01:28:47 pm »

Quote from: Half-Left;4986516
I've just compiled GIMP 2.5.x branch I thought I'd share with you some of the new features already implemented.

User Interface

One of the main issues people talk about with GIMP is the default layout and window management, tool and layer palettes have their own window, well not any more. GIMP 2.5.x already has the option to put everything into one window, a real deal maker for most who are used to applications like it (Photoshop ect..)

The toolbox now has a nice GIMP image behind it instead of a menu bar for options, it's much cleaner.

2.5.x window setup


GEGL

Some of the features I miss or you my know in Photoshop is a ability to add layer effects like dropshadows, glows and bevels onto the layer and adjust them in real time. GIMP 2.5.x now has this sort of options, there is nothing worse then having to guess at adding a shadow and then having to adjust it on it's own layer, thankfully 2.5.x does this like layer effects now which is much easier to manage.

It's rather slow at the moment but I'm sure speed will pickup in later development. These two features alone should get more attention for GIMP as a Photoshop alternative and are much needed.

GEGL at work


You better get ready for GIMP 2.6, it's going to be a real awesome release. :guitar:


I wanted it bad, but it needs two new libraries: babl and gegl. Babl compiled like a charm,but i couldnt get gegl (error at make..) ,probably because my version of glib2 is too old (it needs a newer glib2! and probably gtk, if we have them at the repo,it will be possible to get gimp 2.5)..
babl and gegl at slacky.it are too old,and dont work,tried them too. Aint it a shame when ubuntu users can put their hands into the honey pot,while slack derivatives have to wait once again..

according to its bugzilla,its useable (no critical bugs,not many bugs,only things to change)
« Last Edit: June 19, 2008, 12:09:33 pm by blurymind » Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #1 on: June 19, 2008, 12:08:20 pm »

to compile gimp,i need at least glib 2.14..the one at the repo (which i have) is..lets see...2.12
the latest stable is 2.16... upgrading glib would mean doing the same for gtk

would love to wait for next glib and gtk to come to the repo, but would also love to compile them myself,altho i dont think im worthy do such a serious lib for the repo... basically,i found that it stops me from installing a couple of other cutting edge gtk applications.

so my question is : how do i upgrade glib2 and gtk after i get their source...do i need to pass some special configure options before make?

I'm guessing that would be playing with fire,possibly will mess up all my gui

« Last Edit: June 19, 2008, 12:11:28 pm by blurymind » Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: June 19, 2008, 12:56:03 pm »

you can try adding the vector current repo and upgrading glib and gtk from there
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3195



« Reply #3 on: June 19, 2008, 01:23:32 pm »

you can try adding the vector current repo and upgrading glib and gtk from there

I have done this a couple of times, and it works... I've got the GTK, glib, gcc and others from there
Some things fail to download, but you can find them at slacky.eu or packages.slackware.it download/install from there, and then do the slapt-get  thing... that will work
Logged

caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #4 on: June 19, 2008, 08:02:00 pm »

One thing I don't want to see if new glib2 and gtk+ in the repos during a release cycle.  Some of us remember what happened in 5.8.  For those of us who do automated patch application and upgrades in broke Wifi-radar.  It could have been much, much worse.  These are core libraries for so many packages that the potential for breakage is truly huge.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1553


I like the bass to go BOOM!


WWW
« Reply #5 on: June 19, 2008, 10:51:30 pm »

Quote
One thing I don't want to see if new glib2 and gtk+ in the repos during a release cycle.
Agreed. upgrading from 2.10.x to 2.10.(x+1) might be acceptable, since it's only to fix bugs, but from 2.y.x to 2.(y+a).z certainly isn't, since the changes are too big.

Quote
Some of us remember what happened in 5.8.  For those of us who do automated patch application and upgrades in broke Wifi-radar.
That one was small, somewhere in 5.0 soho or 5.1 Std/Soho "upgrading" gtk+2 had far more dramatic results. I forgot what exactly happened ( too bad the old forums are b0rken ), but I remember it affected far more people and apps back then.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #6 on: June 20, 2008, 06:09:33 am »

where is the current repo.I am willing to risk it in order to get gimp and help its development by reporting bugs and ideas

plus,i can downgrade in the console again if things go too wrong
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #7 on: June 20, 2008, 06:46:48 am »

where is the current repo.I am willing to risk it in order to get gimp and help its development by reporting bugs and ideas

plus,i can downgrade in the console again if things go too wrong
open your /etc/slapt-get/slapt-getrc and change the veclinux-5.9 to veclinux-current so it looks like this
SOURCE=http://vectorlinux.osuosl.org/veclinux-current/packages/

then run slapt-get --install glib2 gtk+2
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #8 on: June 20, 2008, 06:51:39 am »

where is the current repo.I am willing to risk it in order to get gimp and help its development by reporting bugs and ideas

plus,i can downgrade in the console again if things go too wrong
open your /etc/slapt-get/slapt-getrc and change the veclinux-5.9 to veclinux-current so it looks like this
SOURCE=http://vectorlinux.osuosl.org/veclinux-current/packages/

then run slapt-get --install glib2 gtk+2
thanks uel   Grin
 I'll report my progress!
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #9 on: June 20, 2008, 08:40:51 am »

damnit, gimp wants almost the latest version of glib to compile 2.16 !

when will that come to slack-cuurent.

btw i cannot install anything from vector-current repo, hash check error on every-single-package... even when i do it with slapt-get in the terminal and i put -no-hash option,it fails to install.

So i upgraded with slackware-current,which is almost the same,it just doesnt pull any deps like it should..

Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #10 on: June 20, 2008, 08:53:31 am »

Quote
One thing I don't want to see if new glib2 and gtk+ in the repos during a release cycle.
Agreed. upgrading from 2.10.x to 2.10.(x+1) might be acceptable, since it's only to fix bugs, but from 2.y.x to 2.(y+a).z certainly isn't, since the changes are too big.

Quote
Some of us remember what happened in 5.8.  For those of us who do automated patch application and upgrades in broke Wifi-radar.
That one was small, somewhere in 5.0 soho or 5.1 Std/Soho "upgrading" gtk+2 had far more dramatic results. I forgot what exactly happened ( too bad the old forums are b0rken ), but I remember it affected far more people and apps back then.

I do remember that and I do agree with you.  I can understand wanting the latest GIMP but I really believe that this sort of "upgrade" is like playing with fire.

Slackware doesn't support dependency checking which, IMHO, is a major downfall of vanilla Slack and one of the major reasons to run VL instead.  I'm always a bit concerned when folks are pointed to Slackware packages.  All too often dependency problems arise.

@blurymind:  I do understand that you have a specific need or want for the latest GIMP and I am not saying you shouldn't do what you need to do.  I'm just trying to discourage others from following unless they truly have a compelling need to upgrade GIMP.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #11 on: June 20, 2008, 12:06:29 pm »

well thanks cait... i guess the adventurous spirit is not leaving me now,and i do feel a bit unsaisfied by my defeat.  I do not dare compile glib at this point.Maybe wait for a package to come for a couple of weeks first. Damn,its so unfair that ubuntu gets the latest updates and slackware doesnt
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #12 on: June 20, 2008, 01:51:30 pm »

Ubuntu has half the planet developing/packaging for them as well Smiley
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #13 on: June 21, 2008, 03:25:14 am »

ubuntu,man... they mean business  Tongue
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #14 on: June 21, 2008, 05:15:13 am »

ubuntu,man... they mean business  Tongue

I've been through the Ubuntu thing I'll keep Vector thank you..
 Smiley
Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!