VectorLinux
August 31, 2014, 11:27:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Laptop fan runs continuously [SOLVED]  (Read 65542 times)
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« on: June 17, 2008, 07:01:10 pm »

Yesterday I made the unsettling discovery that my laptop fan runs almost continually. It's a very quiet fan and although I've been running 5.9 Standard since betas in October or so, I never noticed it until yesterday.

I booted into Vista on the same machine and it runs much cooler there. Fan doesn't run nearly so often.

I always run on AC power, never on battery. I don't use hibernation or suspend mode or anything like that. When I turn off the computer, I really turn it off.

Is there anything I can do about this? I don't want to have the laptop running so hot all the time.
--GrannyGeek
« Last Edit: June 28, 2008, 08:39:26 am by GrannyGeek » Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
LLL
Global Moderator
Vectorite
*****
Posts: 263


The sun is shining...


« Reply #1 on: June 17, 2008, 08:46:26 pm »

I would think you need to look at vcpufreq - it should be in the system folder of your menu. You'll want to set your CPU-scaling to "on demand" so that it ramps down the processor speed when the extra oomph isn't needed. Letting it slow down keeps things cooler, and allows your fan to calm down a little.

...in my experience, anyway!

LLL

P.S. Interesting to note, Flash video drives my CPU nuts, and it's only a minute into a video that my fan whirrs to life in what sounds like an e-panic to cool things down...
Logged

Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
caitlyn
Packager
Vectorian
****
Posts: 2874


WWW
« Reply #2 on: June 20, 2008, 10:13:15 am »

What brand of laptop is this?  I know that on Toshiba laptops the fan is controlled by ACPI and the toshiba_acpi module is not included in the VL kernel.  If it isn't a Toshiba (and I'm assuming it isn't) is ACPI enabled?  Also, some laptop brands do have utilities specific to their hardware for Linux.  Again, for Toshiba there are toshset (CLI) and toshutils (CLI and GUI) which allow you to turn the fan on and off manually.  I don't think Toshiba is unique in this regards.

For Toshiba users, toshset is in the repos for both 5.9 (testing) and 5.8 (extra).  toshutils is only in 5.8 so far but I'll get around to figuring out why I've had problems building a 5.9 package eventually.  The 5.8 package does work in 5.9.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: June 21, 2008, 05:52:25 pm »

I would think you need to look at vcpufreq - it should be in the system folder of your menu. You'll want to set your CPU-scaling to "on demand" so that it ramps down the processor speed when the extra oomph isn't needed. Letting it slow down keeps things cooler, and allows your fan to calm down a little.

When I run vcpufreq, I'm at a dead end right at the start:
cpufreq driver    UNAVAILABLE

I don't see CPU-scaling as an option. Actually, I don't understand anything in there and tried
man vcpufreq
but there is no man for that command.

Where do I go from here? The CPU is an AMD Turion 64 X2 TL-56.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #4 on: June 21, 2008, 06:10:07 pm »

Caitlyn,
The laptop is a Gateway purchased in August, 2007. ACPI is enabled through VASM.

I have to get this fixed or I won't use VL on this laptop. The difference in how hot it gets when running Vista as compared to running 5.9 Standard is astonishing. I did Web browsing and some other tasks for about three hours in Vista today and the case was cool to the touch. And while hot air could be felt at the fan outlet, the fan ran very infrequently. I then rebooted to VL and the case was cool and fan not running at the start of my session, but after about 15 minutes the case is quite warm, the fan is running full tilt and louder than it ever is in Vista, very hot air is streaming out of the fan outlet, and the palm rest is getting warm.

I wondered why I hadn't noticed this before and then I realized that from the time VL 5.9 was up to Release Candidates, I nearly always ran Linux on the laptop and didn't used Vista often or for very long. The fan isn't loud and I probably assumed the laptop was running in VL the way it was supposed to. It wasn't until I needed to run Vista a few days ago for a more extended period that I noticed how much cooler and quieter the laptop was running.

The laptop never got so hot that it turned off by itself, but I hope I haven't shortened its life by running it so hot for so many months.

I'll be very grateful for any suggestions on how to make it run right.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #5 on: June 21, 2008, 06:11:52 pm »

Without seeing your lsmod, I'd bet you need to load a module:
Quote
modprobe acpi_cpufreq
Now try vcpufreq again. I use "on demand".  vcpufreq will load cpufreq_ondemand at startup if you wish.  In turn acpi_cpufreq and freq_table will load as deps.
HTH
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: June 21, 2008, 10:12:59 pm »

Without seeing your lsmod, I'd bet you need to load a module:
Quote
modprobe acpi_cpufreq
Now try vcpufreq again. I use "on demand".  vcpufreq will load cpufreq_ondemand at startup if you wish.  In turn acpi_cpufreq and freq_table will load as deps.

Thanks very much for this suggestion. I tried
modprobe acpi_cpufreq
and got this response:

root:# modprobe acpi_cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.22.14/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

However, I see acpi-cpufreq.ko in the exact path above. I tried
modprobe acpi-cpufreq
and got another No such device message. I also tried insmod acpi_cpufreq and insmod acpi-cpufreq and was told:
insmod: can't read 'acpi-cpufreq': No such file or directory
I tried all of these as root, of course.

In lsmod I already have freq_table listed. acpid is listed in the processes, as are kacpid and kacpi_notify.

What's the next step?
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
kukibl
Guest
« Reply #7 on: June 22, 2008, 12:59:28 am »

GrannyGeek for AMD Turion you should load powernow-k8 module and then run vcpufreq utility. Ondemand is probably the most suitable governor for every day use.

Module acpi_cpufreq, as far as I know, is for Intel CPUs and it is used instead some deprecated modules in 2.6.20.7 and newer kernels.
« Last Edit: June 22, 2008, 01:03:20 am by kukibl » Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #8 on: June 22, 2008, 04:45:39 am »

Yikes!  If that's the case, I'm sorry GG.  Didn't even think about you using a different processor.
Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #9 on: June 22, 2008, 05:10:11 am »

Just booted my mother inlaw's VL/Turion...

kukibl is right Smiley  Sorry again!
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #10 on: June 22, 2008, 09:12:14 pm »

I modprobed powernow-k8 and now vcpufreq lets me choose a governor. I've selected ondemand, as advised here.

So thanks *very much* to all who helped get me this far. The fan is not running. However, I have to make sure it comes on sometimes, and so far it hasn't. The case feels warm, much warmer than it feels after several hours of use in Vista. Is there a description anywhere of what the various governors do?

The fan has now turned on. Now I'm interested in how long it runs before it turns off.

I HOPE this solves the problem, as I was getting pretty lonely for VectorLinux, even though I like Vista well enough. I prefer to use Linux.
--GrannyGeek

Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
kukibl
Guest
« Reply #11 on: June 23, 2008, 12:40:42 pm »

Is there a description anywhere of what the various governors do?

http://gentoo-wiki.com/HOWTO_CPU_Frequency_Scaling#Governor I hope this helps... Smiley
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #12 on: June 23, 2008, 01:12:40 pm »

Sorry I'd missed this thread before. In 5.8, we had it set up so it would attempt to load all the cpufreq modules on boot. This is described as totally safe in the cpufreq kernel docs, as only the correct one will actually load. For some reason this was left out in 5.9, so you have to add it manually to rc.modules or someplace similar.

A little tip for using the conservative governor: it tends to go down too fast and stay way too long in the min freq setting (at least for my taste), so raise the lower freq limit to something acceptable if the min is too low. In my laptop, the min is 300 MHz, and boy does it get slowwwww....  Grin   The min and max limits can let you finetune the range of freqs the governor can operate in, you can even keep your CPU permanently below the max freq, for longer life/lower power use, etc.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #13 on: June 23, 2008, 05:16:19 pm »

Is there a description anywhere of what the various governors do?

http://gentoo-wiki.com/HOWTO_CPU_Frequency_Scaling#Governor I hope this helps... Smiley

Thank you very much for that. I'll give it a closer look when I have a chance. I've read the governors section and now have a better understanding of the options. There's a link to a HOWTO PowerNow! article that should be informative, too.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #14 on: June 23, 2008, 05:39:55 pm »

Sorry I'd missed this thread before. In 5.8, we had it set up so it would attempt to load all the cpufreq modules on boot. This is described as totally safe in the cpufreq kernel docs, as only the correct one will actually load. For some reason this was left out in 5.9, so you have to add it manually to rc.modules or someplace similar.

A little tip for using the conservative governor: it tends to go down too fast and stay way too long in the min freq setting (at least for my taste), so raise the lower freq limit to something acceptable if the min is too low. In my laptop, the min is 300 MHz, and boy does it get slowwwww....  Grin   The min and max limits can let you finetune the range of freqs the governor can operate in, you can even keep your CPU permanently below the max freq, for longer life/lower power use, etc.

Thanks for the tips. I see we can experiment to find the settings we're happiest with. Right now I'm using ondemand and it seems pretty good. The fan is definitely running much less often than it was before. I hope this means the CPU is running cooler.

I'm monitoring the temperature with System Profiler and Benchmark. I'm not sure how reliable it is, as yesterday with ondemand the temperature was reported as around 70 degrees C. I have difficulty thinking it was really that hot, as I think the computer would have shut down. I've heard from some techie types that software temperature monitors aren't all that reliable in laptops, as they often don't interact that well with the monitoring software.

Is cpu-freq intended for laptops or is it useful for desktop systems, too? I tried to load a cpu-freq driver today on my Celeron Tualatin desktop using modprobe acpi_cpufreq and I got a "no such module" message (meaning I was trying to load the wrong one). Does anyone know what the correct module would be for a 1.3 GHz Celeron Tualatin in a tower computer? Maybe these aren't intended for desktops.

Heat has never been a problem on that system, so I'm asking out of curiosity rather than need.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!