VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: gksu calls kbuildsycoca, forgets password, ignores "nopasswd" in sudoers  (Read 1922 times)

silentstone

  • Member
  • *
  • Posts: 25

I tried to use gksu to start wifi-radar and vwireless as non-root from xfce panel launchers, but they didn't start properly (would open an xterm but never populate it or bring up the graphical interface.  So, I tried again from the command line, and noticed a call by kbuildsycoca, which is KDE.  Why is a GTK tool that uses GTK applications calling KDE?

Also, I would like to not have to type in root's password everytime I connect wirelessly. /etc/sudoers has a WIFI command group defined for %users, and "ALL=NOPASSWD" for WIFI by %users.  Yet my user in that group still needs to enter root's password every time.
Logged

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046

If you are using gksu from our repo I'm very puzzled.  I built that waaaaaaay before 5.9 Standard went gold.  So there was no chance of KDE deps getting pulled in.

As far as your sudoers file goes, you must have the command that is going to be used (full path) in the WIFI command group.

Quote
WIFI=/sbin/iwconfig,/sbin/vwifi2,/sbin/modprobe,/usr/sbin/wifi-radar,/sbin/dhcpcd,/sbin/ifconfig,/sbin/vwireless

And to launch the command as normal user you need to call it like so:
Code: [Select]
sudo /sbin/vwirelessYou'll need the full path since vwireless is only in roots path.
HTH
Logged

silentstone

  • Member
  • *
  • Posts: 25

exeterdad, thank you.  After putting /sbin/vwireless in sudoers, I can use it from a command line as normal user without require root's password.  ifconfig, iwconfig, and dhcpcd also work fine with non-root user.  However, /path/to/wifi-radar (/usr/sbin/wifi-radar, IIRC not in front of Vector at the moment) is likewise in sudoers, but still asks for password.

As for kde being called...I don't have any extra KDE programs installed.  The only desktop environments installed are XFCE, fluxbox, MWM, TWM (and I've only used the 1st two) all of which were installed from the Standard installation CD.  Anyway, after starting wifi-radar, htop showed kdesu (it may have been kdesud) and a couple of other KDE-related things.  I'll have to check again when I'm on the Vector laptop.

Puzzling.
Logged