VectorLinux
October 21, 2014, 06:43:50 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Using GFTP - SOLVED  (Read 1201 times)
Martin109
Vectorite
***
Posts: 290


« on: June 07, 2008, 12:36:53 pm »

I'm familiar with FileZilla, which I've used under Windoze to upload files to my webspace.

I see that GFTP is very similar and available already under VL.

Here is a file stored on my web space.

From this you'll see that my web space is at:

http://web.ukonline.co.uk/martinsawers

and the directory 'Personal%20Web%20Page_files' stores my files.

I'm not telling you my password! Wink

What should I enter into GFTP to list my remote webspace files and enable uploading?  At present it's denying me permission, even though I've entered my username and password.
« Last Edit: June 23, 2008, 07:28:08 am by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
tomh38
Vectorian
****
Posts: 913



« Reply #1 on: June 07, 2008, 01:05:20 pm »

Assuming you entered the correct ip address for "Host" and 21 (the default) for "Port," I can't think of anything you might be doing wrong, unless perhaps your web hosting service requires that you use sftp or something like that to upload files (I can't imagine why they would).

So ... I would make sure of a few things: 1) That you've entered the correct ip for your web space at "Host," that you've entered "21" at "Port," and that you are entering the correct username and password.  Beyond that I can't imaging what could be wrong, assuming that up until now you've been able to upload using Windows and haven't made any relevant hardware changes (e.g. adding a router).
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: June 08, 2008, 03:11:43 am »

Assuming you entered the correct ip address for "Host" and 21 (the default) for "Port," I can't think of anything you might be doing wrong, unless perhaps your web hosting service requires that you use sftp or something like that to upload files (I can't imagine why they would).

So ... I would make sure of a few things: 1) That you've entered the correct ip for your web space at "Host," that you've entered "21" at "Port," and that you are entering the correct username and password.  Beyond that I can't imaging what could be wrong, assuming that up until now you've been able to upload using Windows and haven't made any relevant hardware changes (e.g. adding a router).

I'm puzzled, because I can't get this to work.  I didn't know about Port 21, so thanks for that.

My settings are:

Host: web.ukonline.co.uk (I've also input this as 'http://web.ukonline.co.uk', but GFTP reverts this to 'web.ukonline.co.uk' when I refresh.
Port: 21
Username: martinsawers
Password: [password]
Button with (FTP, FTPS, HTTP, HTTPS, Local, SSH2, FSP): HTTP (if I choose anything else from the list, GFTP just reverts to HTTP on refresh.

The error message I get is:

Code:
<hr />
<address>Apache/2.0.50 (FreeBSD) Server at web.ukonline.co.uk Port 80</address>
</body></html>
HTTP/1.1 403 Forbidden
Date: Sun, 08 Jun 2008 10:50:56 GMT
Server: Apache/2.0.50 (FreeBSD)
Content-Length: 289
Content-Type: text/html; charset=iso-8859-1
Disconnecting from site web.ukonline.co.uk

a) why is it referring to Port 80?
b) Why is it forbidding access when my username and password are correct?
c) the above http link in this post gets the same result, but one would expect that, as no username or password is included.
d) I've tried all the following in the Host window:
web.ukonline.co.uk
http://web.ukonline.co.uk
http://web.ukonline.co.uk/martinsawers
http://web.ukonline.co.uk/martinsawers/Personal%20Web%20Page_files

all with Port 21, and correct username and password.

Every time I get the same error message.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #3 on: June 08, 2008, 04:40:28 am »

Host: web.ukonline.co.uk Port:21 User:martinsawers Pass:****** and select ftp from the spin button.
I tried it and of course was rejected because or wrong pass, but it appeared to work correctly.
« Last Edit: June 08, 2008, 04:44:12 am by exeterdad » Logged
Martin109
Vectorite
***
Posts: 290


« Reply #4 on: June 23, 2008, 07:28:43 am »

Don't know why, but it seems to be working OK now.  Thanks for the help.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!