VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Midnight commander- can't read text- too light?  (Read 2044 times)

tracyf

  • Member
  • *
  • Posts: 15
Midnight commander- can't read text- too light?
« on: June 25, 2008, 08:29:17 pm »

Ok,

This'll sound weird, I know...but I'm trying to use pyNeighborhood to browse my MS network. I managed to muddle my way through setting that up (after adding "wins" to the "hosts dns"- which gave me dhcp, somehow).

Anyway, now I get "mc" when I mount a MS share- but the window text is light/bright yellow (barely readable, and only if I stare really hard)- and the contents column is so light gray that I can only read each line if I click it.

Please tell me there's either a fix to this or another way to browse my network?

TIA,

Tracy
Logged

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Midnight commander- can't read text- too light?
« Reply #1 on: June 26, 2008, 04:19:03 am »

You can customize the colours used by MC - have a look in ~/.mc/ini for a section labeled [colors] (if I remember correctly. There should be two sections to customize - one for the file manager, one for the editor.

You didn't say what colours you are currently getting. The default MC colours are a blue background with bright white for directory entries, grey for normal files, plus some other colours for specific file types (bright green for executable files, for instance). If you are not getting those colours, try finding the keyword in ~/.mc/ini and comment it out. Then restart MC and see what you get.

There should be a few sample colour schemes around - try a Google search. If you can't find anything, let me know, I can probably dig up a URL for you.

paul.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: Midnight commander- can't read text- too light?
« Reply #2 on: June 26, 2008, 05:22:38 am »

Quick and dirty fix: delete the .mc directory in your home dir.
Logged

tracyf

  • Member
  • *
  • Posts: 15
Re: Midnight commander- can't read text- too light?
« Reply #3 on: June 26, 2008, 09:39:37 pm »

Ok-

Saying "quick & dirty", while intriguing, doesn't explain why?

Expand, please?

T
Logged

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Midnight commander- can't read text- too light?
« Reply #4 on: June 28, 2008, 03:39:09 pm »

Ok-

Saying "quick & dirty", while intriguing, doesn't explain why?

Expand, please?

T

 ;D I replied to this earlier, but the reply seems to have vanished with the latest forum problem. So, I hope you haven't already seen this...

When you create a use account under Vector, data from /etc/skel is copied to the new user's home directory. In Vector's case, this includes a .mc directory which establishes some defaults (including colour settings) for MC. By deleting that directory, you force MC to create a new set of defaults, which will not include any colour settings, so the original defaults will be used.

I didn't suggest that option in the first place because I use MC a lot, and set things up to suit my use pattern. So I would be very unhappy to lose the contents of ~/.mc

paul.
Logged