VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: aMule??  (Read 2362 times)

AmericanBob

  • Member
  • *
  • Posts: 2
aMule??
« on: July 05, 2008, 04:44:58 am »

Hello all,
I noticed aMule isn't on any of the repos.
So I thought: no worries. I'll just compile from source...

Except - libcrypto++ is ALSO not on the repos.
I mean, I suppose I could carry on and compile libcrypto++, and so on and so on.

But, seriously. libcrypto++ is one of the most basic packages on most distros - as is aMule. Am I just missing them somewhere?

Ta,
AmeriBob
Logged

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: aMule??
« Reply #1 on: July 05, 2008, 11:45:38 am »

I haven't compiled this application since 5.8. When the application was updated it no longer worked on my 5.8 install, simply for the reason you mentioned.

Quote
But, seriously. libcrypto++ is one of the most basic packages on most distros - as is aMule.
Um we aren't really like most distros  :)

I will try to grab some time to make aMule package to put into the repo, but I do not have much time to keep that package updated, and it would be better for another packager if they have such time. I'll happily start a package for testing, if someone else would like to take over from there.

meantime keep an eye on the testing section of the repo.
Logged

AmericanBob

  • Member
  • *
  • Posts: 2
Re: aMule??
« Reply #2 on: July 05, 2008, 01:05:25 pm »

That's brilliant, but libcrypto++ is probably a more serious concern...
I mean, I can package up aMule - even the CVS version - when the crypto lib is in the repos for the group (though coming from Ubuntuland it may take me a bit longer to figure HOW to get it to someone to put in the repos.  ;) )

I just thought I might have gone mad there, not finding EITHER of them anywhere!

Seriously - shall I try to find the source for libcrypto++ and package it for you?

[edit] Blimey! Just looked, and SLACKWARE doesn't even have the package for libcrypto++ or aMule... That's just bonkers! Is it seriously true than anyone wanting to use aMule on Slack (a bloody big distro...) has to compile a LIBRARY and aMule from first principles? Seems a bit extreme to me...

AmeriBob
« Last Edit: July 05, 2008, 01:12:51 pm by AmericanBob »
Logged

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: aMule??
« Reply #3 on: June 22, 2012, 09:09:21 am »

Using vpackager, I was able to create an aMule package (aMule-2.2.6-i586-1vl70.txz).  The most recent aMule is 2.3.1 rather than 2.2.6, which is the previous release.  However, for 2.3.1, it required wxWidgets 2.8.12, but VL-70, which I'm using, only has 2.8.11, so I had to go for the previous version of aMule.

To create the package with vpackager for VL-7.0 stable, install the following from Gslapt:

cryptopp 5.6.0-i586-1vl70 (satisfies requirement for libcrypto++)
wxWidgets 2.8.11-i586-3vl70
wxGTK 2.8.11-i586-3vl70

Then download aMule-2.2.6.tar.bz2, and run vpackager on the file.  It will create aMule-2.2.6-i586-1vl70.txz in the tmp directory (specifically /tmp/vpackager/aMule/2.2.6).  Install this by right-clicking on it in the file-manager (Thunar).
« Last Edit: June 22, 2012, 09:14:37 am by MarkGrieveson »
Logged
I am using VL7.0 standard with XFCE