Author Topic: Errors when running programs through terminal, but fine when ran through GUI...  (Read 2759 times)


  • Member
  • *
  • Posts: 27
What's the difference between clicking an app to run it through my File Browser than running it through a command in the command prompt?

There's two apps that are kind of annoying. Instead of just typing out the command, I have to navigate through to the directories. One of them is Quake II, which I run through wine. When I run it through terminal with
Code: [Select]
$wine /home/user/.wine/drive_c/Games/Quake_II/quakeII.exeI get an error dialogue that pops up saying "Couldn't load pics/colormap.pcx", and in the terminal, it says "recursive shutdown". But when I do a simple click and run, it runs great (better than it ran when I played it on Windows XP, actually).

On the otherhand, I have a few videos located in my root (i.e. /home/user/ ). They are a bunch of real media (.rm) files. I expected to play them with either mplayer or vlc player with just a click or two. But I have to play them with mplayer through the terminal. Otherwise, when I click through my file browser (which is thunar, by the way), I just get errors within the media players.

What I'm wondering is, what is the difference between running apps through terminal or through a simple point and click? Doesn't either process still access and run the same files? I wonder what the problem is...
« Last Edit: July 25, 2008, 08:13:40 pm by fightingspirit »


  • Administrator
  • Vectorian
  • *****
  • Posts: 1901
First the parameter for Quake 2 is wrong or the file is missing.
Quake2 runs natively in linux, no need for Wine.

Now for the mplayer problem what are the errors?

Issuing a command from the GUI is the command that the
writer of the GUI wanted. Which is why when you want to
debug something you start from a terminal. For example
if you wish to run Firefox, you type firefox in the terminal
instead of clicking an icon.



  • Packager
  • Vectorian
  • ****
  • Posts: 1144
What I'm wondering is, what is the difference between running apps through terminal or through a simple point and click?

The commands for the GUI applications (the ones that are executed when you click on an icon) are in the program's .desktop files (usually inside /usr/share/applications). These might not be exactly the same command as you think. That is, they might be different from the ones you run in the Terminal. For example, when you view the .desktop file for mplayer, it shows:
Code: [Select]
username:$ cat /usr/share/applications/mplayer.desktop

[Desktop Entry]
GenericName=Multimedia player
Comment=Multimedia player
Comment[es]=Reproductor multimedia
Comment[fr]=Lecteur multimédia
Comment[it]=Lettore multimediale
Exec=gmplayer %U

As you can see in the exec line, the icon actually runs gmplayer, while when you run it on a terminal you're running mplayer. I don't know if that is the cause of the errors, but if you try gmplayer in the Terminal, it should be the same thing as clicking the file or the icon.

Maybe for Quake, the "GUI command" (written in the .desktop file) is also different from what you're running in the Terminal.... I guess.
Hope this helps.