VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VASMCC not working....[SOLVED]  (Read 1266 times)

Cariboo

  • Vectorite
  • ***
  • Posts: 289
VASMCC not working....[SOLVED]
« on: July 11, 2008, 07:37:30 pm »

Hello all,
I have problems with VASMCC.
I wanted to install a printer (Menu --->System --->VASMCC --->Services --->CUPS Printing)
and I can't open VASMCC, neither as root nor as user.

I attached the hardware info of the computer I'm working with.
I checked with 'Gslapt' and found the package installed (see attached sreenshot).

What else should I post here or could I do to find out what's wrong?
 ???
« Last Edit: July 13, 2008, 06:02:20 am by Cariboo »
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: VASMCC not working....
« Reply #1 on: July 11, 2008, 10:27:31 pm »

Open a terminal, login as root, type "vasmCC" and tell us what you get.
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: VASMCC not working....
« Reply #2 on: July 12, 2008, 06:29:25 am »

Open a terminal, login as root, type "vasmCC" and tell us what you get.

Thanks for the reply!

here is what I get from 'root:# vasmCC':

Quote
Password:
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
vector://home/reni
root:# vasmCC
WARNING: current bytecode version is 1.9.49 and project bytecode version is 2.0.0.
.....
......This line is repeated about 20 times
....
WARNING: current bytecode version is 1.9.49 and project bytecode version is 2.0.0.
/usr/bin/vasmCC: line 4:  9127 Segmentation fault      LD_LIBRARY_PATH="/opt/vpackager/lib/gambas2" PATH="/opt/vpackager/bin:$PATH" /usr/bin/vasmCC.gambas
vector://home/reni
root:#
« Last Edit: July 12, 2008, 07:00:50 am by Cariboo »
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VASMCC not working....
« Reply #3 on: July 12, 2008, 08:36:56 am »

your gambas2-runtime package is outdated

You should have at least version 2.5. And also, seems your vasmCC is old

Post the output of
Code: [Select]
ls -al /var/log/packages | grep -i vasmcc
You can find the latest vasmCC package at http://vasmcc.googlecode.com
« Last Edit: July 12, 2008, 09:32:52 am by M0E-lnx »
Logged

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: VASMCC not working....
« Reply #4 on: July 13, 2008, 05:21:03 am »

And also, seems your vasmCC is old
Post the output of
Code: [Select]
ls -al /var/log/packages | grep -i vasmcc

Thank you, MOE-inx,

I checked Gslapt and found
"gambas2-runtime installed version 2.5.0-i586-1vl59"
so, this is OK then, right?

here is the output of 'root:# ls -al /var/log/packages | grep -i vasmc':

Quote
-rw-r--r--  1 root root    3236 2007-11-18 20:45 vasmCC-1.06-i586-3vl59
vector://home/reni
root:#

 I installed the newest version from http://vasmcc.googlecode.com
and now I can open vasmCC  from
--->Menu --->System --->Vector Control Center
and I could install the printer.
Case closed.
Thank you ;)

« Last Edit: July 13, 2008, 06:01:44 am by Cariboo »
Logged
Life is full of setbacks; Success is measured by the way you deal with them!