Please support VectorLinux!

Author Topic: No Login with Dillo  (Read 1832 times)

Pita

  • Vectorian
  • ****
  • Posts: 1324
No Login with Dillo
« on: July 14, 2008, 12:22:00 am »
As of late I can't login anymore into VL Forum using dillo browser. I just get a blank page.

What has changed and can it be corrected? I am so used to dillo.

Regards

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: No Login with Dillo
« Reply #1 on: July 14, 2008, 06:19:42 am »
Hmmmm  Our forum software was updated to the latest version.  I found my bash script that I made to log in to the board and post new package announcements was failing. SMF has changed the way logins are handled. SMF's final login stage is a meta redirect. Meaning before the login is completed, a url is sent back to the browser in the http headers.  This url also has needed variables to validate the user.

In short, from a quick Googling, Dillo doesn't seem to follow meta refresh/redirects well.
Dillo users might have a problem here. :(

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: No Login with Dillo
« Reply #2 on: July 14, 2008, 06:42:21 am »
I figured out a workaround!

Make sure cookies are enabled for our forum.  Cookies in dillo disabled by default.

Edit /home/you/.dillo/cookiesrc to look like this:
Quote
DEFAULT DENY
supergamer.org ACCEPT_SESSION

Then open dillo and attempt to login as usual.
It should fail as before.
Click your mouse in the address field so the flashing cursor is there. Hit Enter.  It will act as a redirect and pass the final info to the server and log you in.

Enjoy :)

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: No Login with Dillo
« Reply #3 on: July 14, 2008, 10:48:40 am »
Nice... Dillo is the fastest browser I know.. the only problem I have w/ it is that it is way too barebones.
my forum session expires every 5 minutes or so even if I check the "forever" login time.

other than that, it's kool

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: No Login with Dillo
« Reply #4 on: July 14, 2008, 07:20:11 pm »
I figured out a workaround!

Make sure cookies are enabled for our forum.  Cookies in dillo disabled by default.

Edit /home/you/.dillo/cookiesrc to look like this:
Quote
DEFAULT DENY
supergamer.org ACCEPT_SESSION

Then open dillo and attempt to login as usual.
It should fail as before.
Click your mouse in the address field so the flashing cursor is there. Hit Enter.  It will act as a redirect and pass the final info to the server and log you in.

Enjoy :)

Thanks! Worked great. Back in dillo, sigh.

My forum session has never expired. Yes dillo is just great and fast, reading papers, searching in amazon you name it. If java or frames are needed I go as far as possible in dillo, then copy URL over to firefox or opera and continue from there.