VectorLinux
December 21, 2014, 05:05:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: wireless WG111T USB adapter  (Read 2544 times)
multsystem
Member
*
Posts: 2


« on: August 03, 2008, 03:04:06 am »

I am trying to put this adapter working in my desktop, but i am almost giving up...

What i did?wpa

a found the WindowsXP driver on the CD and then:

ndiswrapper -i
ndiswrapper -l
ndiswrapper -m
depmod -aq
modprobe ndiswrapper

Ok, after iwconfig i saw my card. After i put some information on /etc/wpa_supplicant.conf and then:

wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf

but it's not working.


My router use WPA, with static ip.
Logged
hata_ph
Packager
Vectorian
****
Posts: 3261


-- Just being myself --


« Reply #1 on: August 03, 2008, 04:18:28 am »

pls provide your lspci, lspcmcia and lsmod....
what version of VL you are using?
Logged
multsystem
Member
*
Posts: 2


« Reply #2 on: August 03, 2008, 12:03:55 pm »

It's a usb adapter, but my lsusb return ok. My adapter is ok. I can do a scan with
iwlist wlan0 scan
and see my network but it's not getting  conected.


VL STD 5.9...
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #3 on: August 03, 2008, 03:20:56 pm »

Start with simple steps. Disable the security first since that
will add more to troubleshoot.

iwconfig will give interface information about the current
settings. Test the essid first then go from there.

HTH

Bigpaws
Logged
aixuser01
Member
*
Posts: 86


« Reply #4 on: August 04, 2008, 08:41:09 pm »

Hi, I am running vl 5.8 and one mistake I made was using the ndiswrapper as the driver like this
wpa_supplicant -B -Dndiswrapper -iwlan0 -c /etc/wpa_supplicant.conf

I went to the ndiswrapper at sourceforge
http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,wpa/
and found you should call it with the wext driver like this
wpa_supplicant -B -Dwext -iwlan0 -c /etc/wpa_supplicant.conf

wext will figure out the device is supported with ndiswrapper and call it under the covers. Once I made this change it worked fine for me.

one other issue, I had to try several different winxx drivers before I could get connected, so you may need to experiment a bit.
I hope this helps.
Logged

Evil Overlord rule 58 My doomsday device will not employ a large red digital countdown device unless it is absolutely necessary.  If a countdown device proves to be necessary, the doomsday device will be set to activate when the counter reaches 00:10:00, rather than 00:00:00.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!