VectorLinux
November 26, 2014, 05:15:17 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Epson CUPS Printer Problem - SOLVED  (Read 10697 times)
Martin109
Vectorite
***
Posts: 290


« on: August 03, 2008, 07:28:24 am »

I'm trying to set up my Epson Stylus Photo 890 printer for use with VL 5.9 Standard.  I've used VASMCC to access CUPS and thought I'd set up the printer right.  The printer summary page shows:

Description: Epson Stylus Photo 890 Usual
Location: Slough
Printer Driver: EPSON Stylus Photo 890 - CUPS+Gimp-Print v4.2.7
Printer State: idle, accepting jobs, published.
Device URI: socket://127.0.0.1

.. but when I try to print a test page, CUPS keeps taking to 127.0.0.1 but nothing happens.  Also if I try and print a test page from a text editor, nothing happens.

Could it be the Device URI?  The help information seemed to suggest that 'socket://hostname' was the right one.

Any help appreciated.

« Last Edit: August 04, 2008, 05:46:48 am by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #1 on: August 03, 2008, 12:20:19 pm »

Try URI: socket://127.0.0.1:9100
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: August 03, 2008, 12:58:41 pm »

Thanks, nightflier.

I tried that, but to no avail.

I gave it 10 mins, just to be on the safe side.

The CUPS page was showing:

Description: Epson Stylus Photo 890 Usual
Location: Slough
Printer Driver: Epson Stylus Photo 890 - CUPS+Gutenprint v5.1.3
Printer State: processing, accepting jobs, published.
Device URI: socket://127.0.0.1:9100

The job section at the bottom of the page showed:

EpsonUsual-6   Test page   Root   17k   1   Processing since Sun 03 August 2008  08:23.10 PM BST

There was activity online, with the system communicating with and waiting for 127.00.1, but no printing!
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #3 on: August 03, 2008, 01:22:44 pm »

Maybe socket://localhost:9100

How is the printer connected to the computer?
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #4 on: August 04, 2008, 01:16:03 am »

How is the printer connected to the computer?

Via a standard parallel printer cable.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #5 on: August 04, 2008, 03:07:44 am »

vasmCC > Hardwareset > enable parallel port by checking box.
Reboot

HTH, Lee
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #6 on: August 04, 2008, 04:00:47 am »

Thanks, Lee.  But still not quite there yet!

Did what you said about enabling parallel port via Hardwareset.

Wouldn't allow printing on socket://127.0.0.1:9100

Reverted to socket://127.0.0.1 when adding printer, having started again.

This time, many more printer set options available, a whole page, a good sign.

But still won't print test page.

I get the message:

"recoverable: Network host '127.0.0.1' is busy; will retry in 30 seconds..."
, but this state goes on, and on, and  on...

Also won't respond to print request from simple text editor.

Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
no2thesame
Packager
Vectorite
****
Posts: 136


« Reply #7 on: August 04, 2008, 04:44:20 am »

Martin, I think there is some issue with CUPS on 5.9 as the Device URI choices don't include the Parallel options.

To fix is simple

as root edit /etc/cups/printers.conf

Replace the line:
Device URI: socket://127.0.0.1:9100 (or whatever you have now)
with

DeviceURI epson:/dev/lp0

save and it should work.

It has nothing to do with the parallel port in my experience.

no2
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4030



« Reply #8 on: August 04, 2008, 04:47:39 am »

For a parallel port printer the URI should be something like
parallel:/dev/lp0

I used to have an Epson connected to the parallel port on my box and it always showed up as an option in the KDE printer wizard. Not sure about the cups web interface.

Edit: I second no2's opinion   Wink
« Last Edit: August 04, 2008, 04:49:47 am by nightflier » Logged
Martin109
Vectorite
***
Posts: 290


« Reply #9 on: August 04, 2008, 05:46:31 am »

Thank you, no2 and nightflier - that's sorted it!

Printed a test page and a doc from AbiWord!

Many thanks.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!