VectorLinux
October 25, 2014, 06:14:20 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Setting Up Madwifi for an Atheros Card - SOLVED  (Read 3606 times)
Martin109
Vectorite
***
Posts: 290


« on: August 03, 2008, 08:43:16 am »

According to Gslapt, madwifi is already installed on this version of VL 5.9 Standard.  How do I activiate it?
« Last Edit: August 05, 2008, 03:52:15 pm by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #1 on: August 04, 2008, 10:44:37 pm »

It should be activated automatically at boot if the Atheros based wireless card is detected.  To check if it is at the command line type:

Code:
lsmod | grep ath

If the driver is loaded you should get a result like this:

Code:
root:# lsmod | grep ath
ath_rate_sample        13952  1
ath_pci               104360  0
wlan                  197168  5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               231776  3 ath_rate_sample,ath_pci

If not then let us know the specifics of your card and the version of VL you are running and someone (maybe me, maybe not) can help you do some troubleshooting.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Martin109
Vectorite
***
Posts: 290


« Reply #2 on: August 04, 2008, 11:21:49 pm »

Thanks Caitlyn.

That's produced results! -

Code:
ath_rate_sample        13184  1
ath_pci                89504  0
wlan                  192964  4 wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               190672  3 ath_rate_sample,ath_pci

What do I do next?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
bigpaws
Vectorian
****
Posts: 1856


« Reply #3 on: August 05, 2008, 04:25:15 am »

http://madwifi.org/wiki/UserDocs/FirstTimeHowTo

Bigpaws
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #4 on: August 05, 2008, 11:18:34 am »

Thanks, bigpaws!

That's clearly tailor-made for a newbie like me. Smiley
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 290


« Reply #5 on: August 05, 2008, 01:57:05 pm »

Right!  I've now got wireless working,  At least on an open AP for now.

The commands that get it going are:

Code:
ifconfig ath0 up
modprobe wlan_scan_sta
iwconfig ath0 ap 00:1b:2f:71:09:98
dhcpcd ath0

How do I automate these, so that wireless comes on automatically on booting?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
nightshift
Member
*
Posts: 22


« Reply #6 on: August 05, 2008, 02:23:15 pm »

Hi Martin109:

    Put:
          ifconfig ath0 up
          modprobe wlan_scan_sta
          iwconfig ath0 ap 00:1b:2f:71:09:98
          dhcpcd ath0

Into /etc/init.d/rc.local or create a script and point to it from /etc/init.d/rc.local

nightshift
Logged
Martin109
Vectorite
***
Posts: 290


« Reply #7 on: August 05, 2008, 03:38:05 pm »

Hi Martin109:

    Put:
          ifconfig ath0 up
          modprobe wlan_scan_sta
          iwconfig ath0 ap 00:1b:2f:71:09:98
          dhcpcd ath0

Into /etc/init.d/rc.local or create a script and point to it from /etc/init.d/rc.local

Hi nightshift.

File rc.local does not seem to exist!  in /etc/init.d, I only have one file called 'wifi-radar'.

Should I create rc.local?

EDIT: Found it in /etc/rc.d !
« Last Edit: August 05, 2008, 03:42:05 pm by Martin109 » Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
rbistolfi
Packager
Vectorian
****
Posts: 2288


« Reply #8 on: August 05, 2008, 03:43:43 pm »

Vector uses /etc/rc.d/rc.local, use that file instead.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Martin109
Vectorite
***
Posts: 290


« Reply #9 on: August 05, 2008, 03:51:54 pm »

Thanks everyone, got that working now.

Working on WPA-PSK and having some problems - will start new thread.

Many thanks.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!