VectorLinux
September 21, 2014, 01:51:05 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Windows Manager Problems with Non-root User  (Read 3583 times)
Martin109
Vectorite
***
Posts: 289


« on: August 08, 2008, 02:33:10 pm »

My installation of VL 5.9 Standard boots fine into xfce as root, but if I try to do this as an ordinary user, I get the screen, icons, and cursor, but no menu bar athe bottom of the screen!  If I then do CTRL-ALT-DEL, I immediately get a screensaver, then if I move the mouse or hit a button I get a 'The system is locked' dialog with ordinary prompting for a password.  If I enter the appropriate password, I just get back to the screen with no menu bar.  very strange!

Any ideas what is going on?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: August 08, 2008, 05:50:23 pm »

Ctrl-Alt-Del is not supposed to reboot.

I think Ctrl-Alt-Del is maybe starting xflock4.
That's specified in Menu > Settings > Keyboard Settings > Shortcuts.
Can you confirm that for me, please?
You can change those keys and assign the lock function to any other combination or delete it all together.

(I assume you can access the menu by right-clicking on the desktop)

If that gets solved, your problem is the lack of a menu bar.
Open a terminal, and type:
Code:
xfce4-panel
That should bring it back.

Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #2 on: August 08, 2008, 05:52:56 pm »

Then again, instead of opening the Terminal, click on "Run Program" on the menu instead.
And type the command above.
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #3 on: August 09, 2008, 10:11:41 am »

Ctrl-Alt-Del is not supposed to reboot.

I think Ctrl-Alt-Del is maybe starting xflock4.
That's specified in Menu > Settings > Keyboard Settings > Shortcuts.
Can you confirm that for me, please?
You can change those keys and assign the lock function to any other combination or delete it all together.

I found the shortcut menu but, even as root, they are all greyed out and I can't change/delete them.

At least, I now know not to use CTRL-ALT-DEL !

If that gets solved, your problem is the lack of a menu bar.
Open a terminal, and type:
Code:
xfce4-panel
That should bring it back.

That does work, but the terminal display hangs, and if I close the terminal window, the menu bar disappears again.

Thanks for the help so far, though.
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #4 on: August 09, 2008, 11:40:05 am »

In a terminal window type in:

xfce-panel &

The & tells Linux to run the terminal process in the background so you can continue to do other work in the terminal.  Next, log off, saving the session settings (that's a checkbox on the logout screen).  That will close xfce and return you to the display manager when you login.  The next time you login both the panel and the terminal will open but the two will no longer be tied together.  You can safely close the terminal and your panel will remain.

The & isn't necessary if you did it from Run Program, obviously.

HTH,
Cait
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #5 on: August 09, 2008, 11:49:46 am »

Quote
I found the shortcut menu but, even as root, they are all greyed out and I can't change/delete them.

You need to click on ADD in that window. That will add a new keyboard shortcut "map" that is based on the defaults but that you can change.
Logged
Martin109
Vectorite
***
Posts: 289


« Reply #6 on: August 09, 2008, 12:20:45 pm »

Quote
I found the shortcut menu but, even as root, they are all greyed out and I can't change/delete them.

You need to click on ADD in that window. That will add a new keyboard shortcut "map" that is based on the defaults but that you can change.

Thanks,wcs, deleted it!
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #7 on: August 09, 2008, 12:34:01 pm »

In a terminal window type in:

xfce-panel &

The & tells Linux to run the terminal process in the background so you can continue to do other work in the terminal.  Next, log off, saving the session settings (that's a checkbox on the logout screen).  That will close xfce and return you to the display manager when you login.  The next time you login both the panel and the terminal will open but the two will no longer be tied together.  You can safely close the terminal and your panel will remain.

The & isn't necessary if you did it from Run Program, obviously.

HTH,
Cait

The only way this newbie knows how to logoff in a way you describe is to click on 'Menu' -> 'Quit'.

If I try to do this, with a terminal window open or not, I can't!  I would expect to see a greyed out desktop with a dialog with three options: Logout, Restart, Shutdown.  But this does not appear!

I HAVE tried:

Code:
shutdown -f now

from the Terminal, but to no avail.  While I can log on again, when I do the menu bar has gone again.

Perhaps there's another way of logging off that I don't know about? Undecided
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #8 on: August 09, 2008, 12:46:07 pm »

Tried this again following a complete reboot.

This time I got a multiple error message on trying twice:

root: xfce4-session-logout: No session manager running
xfce4-session-logout: No session manager running
Error: No running window found
Error: No running window found
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #9 on: August 09, 2008, 01:07:50 pm »

I see from the Settings -> Preferred Applications that there are two terminal emulations - X-Terminal and xfce-Terminal.  Does it matter which is selected?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #10 on: August 09, 2008, 02:03:18 pm »

But what happens when you do xfce4-panel in Menu > Run Program ?
Is it possible to quit and save session when you run the panel that way?
Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #11 on: August 09, 2008, 04:12:13 pm »

You might try copying your xfce configuration from another user (root is fine), change the ownership/permissions, and go back to a default setup.  That may be easier than trying to fix your obviously borked configuration.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Martin109
Vectorite
***
Posts: 289


« Reply #12 on: August 10, 2008, 07:22:01 am »

But what happens when you do xfce4-panel in Menu > Run Program ?
Is it possible to quit and save session when you run the panel that way?

Thanks, wcs, that's worked!

At least, I quit and saved, then logged back in, and the menu bar was there!  Great!
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
Martin109
Vectorite
***
Posts: 289


« Reply #13 on: August 10, 2008, 07:24:08 am »

You might try copying your xfce configuration from another user (root is fine), change the ownership/permissions, and go back to a default setup.  That may be easier than trying to fix your obviously borked configuration.

Thanks, caitlyn.

I haven't had to use this this time round but, for future reference, what would be the name of the configuration file for xfce, where would I find it, and how would I change the permissions on it?
Logged

Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard
sledgehammer
Vectorian
****
Posts: 1424



« Reply #14 on: September 21, 2008, 10:54:33 pm »

I had the same problem some time back and tomh38 solved it for me with the xfce4-panel suggestion.  However, after installing firestarter today, I had the same problem (no panel) and while xfce4-panel worked, I could not save. When I tried to quit, it insisted that I first get out of xfce4-panel and if I did that, it would not reboot with a bottom panel.

So, I tried Caitlyn's suggestion and copied xfce4 configuration files from root to my configuration file and it worked (allowed me to quit after running xfce4-panel).

Now, however, my configuration files are owned by root.  Is there an easy way to change permissions on my /.config/xfce4?

John
Logged

VL7.0 xfce4 Samsung RF511
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!