VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: I always have to install soundcard drivers after restart. [SOLVED]  (Read 3506 times)

Asound

  • Member
  • *
  • Posts: 19

Hello everyone,

as the subjects says, I always have to install the soundcard drivers after every restart. My soundcard is an "Creative X-Fi Xtreme Gaming". Iam using Vectorlinux 5.9.
The installation works very well and Iam having sound, but after a restart its like i never installed the drivers and I have to install them again. Thank god that I dont have to make a restart after the install  :P
Could it be that the drivers arent loaded with the bootup? If yes what can i do?

Hope that someone can help me, because im very new to Linux.

thanks
« Last Edit: August 13, 2008, 05:02:29 am by Asound »
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2321
Re: I always have to install soundcard drivers after restart.
« Reply #1 on: August 12, 2008, 05:09:11 pm »

A guessing, do you have more than a soundcard? maybe a webcam with mic or similar?
That could be one cause for your problem. If you do, follow this: http://forum.vectorlinux.com/index.php?topic=4888.0
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I always have to install soundcard drivers after restart.
« Reply #2 on: August 12, 2008, 07:47:37 pm »

How are these drivers installed? Do you compile them?
Maybe you just need to load a kernel module at boot, with "modprobe <modulename>".
(just guessing here...)
Logged

Asound

  • Member
  • *
  • Posts: 19
Re: I always have to install soundcard drivers after restart.
« Reply #3 on: August 13, 2008, 03:00:34 am »

First of all thanks.

@rbistolfi: My onboard soundcard is disabled but Iam also having an tv-card. When the drivers arent installed, the file ist empty. So it seems that there is no soundcard detectet. After the install of the drivers there appears "0 ctalsa".

@wcs: Well, I have just installed them by running an script thats included, so Iam not sure. But the script self runs an "make" and "make install".
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I always have to install soundcard drivers after restart.
« Reply #4 on: August 13, 2008, 03:32:12 am »

Maybe you'll find the name of a module in the documentation of the drivers.
Then you can type "lsmod" to see if the module is loaded.
It shouldn't be after a reboot, but you can load it by typing "modprobe <module name>"

If it works after the modprobe command, then you can put the command at the end of /etc/rc.d/rc.modules and it should start at boot.

Or this procedure might not apply, but give it a try.
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I always have to install soundcard drivers after restart.
« Reply #5 on: August 13, 2008, 03:38:17 am »

Also you might want to look at the driver's Makefile in the source directory to see what it is doing when it does "make install". Search for an "install" instruction in that Makefile.
There must be something there that doesn't stick (in the previous post, I'm guessing it's a modprobe command). Whatever it is, then it can be made to run at boot.
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I always have to install soundcard drivers after restart.
« Reply #6 on: August 13, 2008, 04:10:28 am »

Duh!...

Of course, the module name is "ctalsa" ! You had said that already (from the /proc/asound/modules file, right?)  ;)

Just try rebooting and doing "modprobe ctalsa".
Logged

Asound

  • Member
  • *
  • Posts: 19
Re: I always have to install soundcard drivers after restart.
« Reply #7 on: August 13, 2008, 04:29:48 am »

Setting the command "modprobe ctalsa" at the end of the rc.modules worked! :)
Booting takes a little bit longer but its still much faster then installing the drivers all again.
Thank you so much!
« Last Edit: August 13, 2008, 04:32:23 am by Asound »
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: I always have to install soundcard drivers after restart.
« Reply #8 on: August 13, 2008, 04:45:53 am »

Cool.
You can edit the title of this thread to put [SOLVED] in in, so that it can be easily found.
Logged