VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Is it ok to disable udev?  (Read 9862 times)

deepsix

  • Member
  • *
  • Posts: 19
Is it ok to disable udev?
« on: August 16, 2008, 10:56:39 am »

I always get errors and slow boot times because of udev......

I recently recompiled my kernel and disabled raid and lvm .... now im getting errors when updating lilo saying device-mapper couldnt be found.

in the config file for udev it calls for the kernel device-mapper which unless im wrong I disabled when i disabled raid and lvm.

any help or suggestions would be appreciated........

btw im running vlight 5.9 on a P2 300 mhz 256 ram
« Last Edit: August 16, 2008, 10:58:28 am by deepsix »
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Is it ok to disable udev?
« Reply #1 on: August 22, 2008, 09:51:23 pm »

Disabling udev or device-mapper is a really bad idea.  Disabling udev effectively disables all removable media.  You wouldn't be able to use USB, PCMCIA, Firewire, etc...
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Is it ok to disable udev?
« Reply #2 on: August 23, 2008, 01:16:36 am »

Ahh the days before udev made our lives easier  ;D
You really should leave it on, as said above. Think of it as your Universal Device Detector. Setting those thing up manually is probably not the way you really want to go.. I'm saying this because if you had to ask whether or not it's ok to disable it, then we are trying to help save you many headaches of setting up devices without it.

Maybe you can post the udev errors in an appropriate section of the forum so the community can help get rid of those errors? And I suspect the errors are the reason for the sloweness (to some extent) .

Logged

deepsix

  • Member
  • *
  • Posts: 19
Re: Is it ok to disable udev?
« Reply #3 on: August 23, 2008, 04:11:22 am »

Thanks for the info....what I finally ended up doing was just re-installing vector to take care of the raid part..
but udev is still hanging at boot on my cdrom something about cant create a symlink and /etc/udev/rules/cdrom devices doesnt exist or somthing like that...I would post output but ive looked through all my log files (/var/log*) and cant find any output from udev...am I looking in the wrong place?
thanx again.
Logged

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Is it ok to disable udev?
« Reply #4 on: August 24, 2008, 12:44:17 am »

Try
Code: [Select]
cat /var/log/boot.logThis will show you the verbose boot sequence where you see all the pretty OK's and Failed's
« Last Edit: August 24, 2008, 12:51:08 am by Masta »
Logged

deepsix

  • Member
  • *
  • Posts: 19
Re: Is it ok to disable udev?
« Reply #5 on: August 24, 2008, 04:11:28 am »

Try
Code: [Select]
cat /var/log/boot.logThis will show you the verbose boot sequence where you see all the pretty OK's and Failed's


This is the only error showing up in syslog There are no errors in boot.log.... At boot udev hangs with errors on cdrom.rules and symlinks but its not in any of the logs... Right now htop says that udev is -4 NI whatever that means.

Aug 19 08:21:18 table8 kernel: ALSA /home/uel/alsa-driver-1.0.16/pci/../alsa-kernel/pci/es1938.c:419: ESS Solo-1 reset failed
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02c6/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02b9/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x022/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02c0/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02b1/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02b1/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x025f/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02c0/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02b2/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02b2/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x025f/0x0280)
Aug 19 08:21:18 table8 kernel: snd_es1938_write_cmd timeout (0x02d1/0x0280)
« Last Edit: August 24, 2008, 04:15:06 am by deepsix »
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Is it ok to disable udev?
« Reply #6 on: August 24, 2008, 08:25:28 am »

Are you running on of the Release Candidates of Vector Linux Liight?  I saw the same thing on the Release Candidates but not on the final gold code.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4109
Re: Is it ok to disable udev?
« Reply #7 on: August 24, 2008, 04:45:51 pm »

Looks like those errors have something to do with your sound card.

For troubleshooting purposes: if it's an on-board chip, you can try disabling it in BIOS. Or, you can try disabling alsa using vasm>super>service>servset>(your runlevel, or all).
Logged

deepsix

  • Member
  • *
  • Posts: 19
Re: Is it ok to disable udev?
« Reply #8 on: August 24, 2008, 10:06:08 pm »

Are you running on of the Release Candidates of Vector Linux Liight?  I saw the same thing on the Release Candidates but not on the final gold code.

No im using 5.9 final
Logged

deepsix

  • Member
  • *
  • Posts: 19
Re: Is it ok to disable udev?
« Reply #9 on: August 24, 2008, 10:13:02 pm »

Looks like those errors have something to do with your sound card.

For troubleshooting purposes: if it's an on-board chip, you can try disabling it in BIOS. Or, you can try disabling alsa using vasm>super>service>servset>(your runlevel, or all).


OK...now im not even getting the boot error messages for udev anymore (dont know what changed) but the system hangs as soon as the system starts coldpugging this is some of the output.

starting udevd /sbin/udev
cannot open /dev/null/
PERFORMING COLD PLUGGING
/dev/.tmp-3-0: unknown volume type
no kernel EDD support  <----------- It sits at this point for almost 40 sec with no output then proceeds to boot normally.

Im still working on the soundcard issue.  but ^ is my main headache even though the soundcard reset fails it only takes about 2 sec to get through.
« Last Edit: August 24, 2008, 10:20:05 pm by deepsix »
Logged

Masta

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 725
Re: Is it ok to disable udev?
« Reply #10 on: August 24, 2008, 11:14:11 pm »

This is a bit tricky to work with since you've recompiled your own kernel (maybe forgot to impliment the udev patch for the kernel in Q?)

However, if you're able to get back to the original VL kernel, I think it would be easier to track this.
As mentioned, it does seem to be (originally) an issue with your sound card which was/is causing the slowdown.
I recommend disabling the soundchip/card in your bios, or remove sound card if it's not integrated onot the motherboard.

If this cures the slowdown (on the default VL kernel) then we've conquered a milestone, and we can then work on a cure for the sound card.
Logged