VectorLinux
December 19, 2014, 05:13:10 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Permission Problem...  (Read 6866 times)
payne
Member
*
Posts: 14



« on: August 17, 2008, 12:44:36 am »

hi all im noobies on linux
i use vl soho

i can't chown the files to the user
but it work for directory

for the info..
my hdd is ntfs...does it cause the problem?

sorry my english  bad...
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #1 on: August 17, 2008, 06:02:40 am »

I am guessing that you are trying for read/write permissions
for a mounted NTFS partition.

What you are doing will probably do bad things to the Windows
permissions.

The proper way is to change the permissions of the mount since
that is what will give you read/write pemissions.

Open VASM and there are mount partition options and irc  you
can change the permissions there.

HTH

Bigpaws
Logged
payne
Member
*
Posts: 14



« Reply #2 on: August 18, 2008, 11:37:13 pm »

i already try that...
but it keep doesnt work...
i mean, i can use chown command for the directories but i cant use it for the files...

when i try to chown the file, it say something like "operation not supported"...
what does it mean...

also with chmod...

pls help me i keep stuck in this problem...

when i use vasm to mount my ntfs partition, it has an option, what should i do with that or just leave it by the default

but what i dont understand is...
"bigpaws : Open VASM and there are mount partition options and irc  you
can change the permissions there. "
i couldnt found where to change permission...
what irc is?

thx...
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #3 on: August 19, 2008, 02:01:27 am »

irc = if I recall.

Please post fstab which is where the permission problem probably
is.

Quote
pls help me i keep stuck in this problem...

I am trying

Bigpaws
Logged
payne
Member
*
Posts: 14



« Reply #4 on: August 20, 2008, 05:44:35 am »

fstab Huh
i'll try to find about that first...
then i'll back after i try that...

thx bigpaws...
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #5 on: August 20, 2008, 09:55:17 pm »

Quote
fstab Huh

That is be the contents of the /etc/fstab file.
This is where you can specify how you want the filesystems to be mounted (with read/write permissions, etc...)
Logged
payne
Member
*
Posts: 14



« Reply #6 on: August 23, 2008, 04:51:45 am »

Ok..
i found this on my fstab file....
----------------------------------------
/dev/hdb5   /mnt/hdb5  ntfs defaults 0 0

/dev/hdb1   /mnt/hdb1  ntfs  defaults 0 0
----------------------------------------

i already try to change like this...

----------------------------------------
/dev/hdb5   /mnt/hdb5  ntfs defaults rw 0 0
----------------------------------------

but it doesnt work?
may i wrong with the options?
honestly, i dont understand with how to put the options...
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #7 on: August 23, 2008, 05:06:18 am »

Here is some fstab information for you:

http://www.openaddict.com/node/31

Bigpaws
Logged
payne
Member
*
Posts: 14



« Reply #8 on: August 23, 2008, 06:10:10 am »

thx, but i already read that tutorial...
could u just give me the example how to put the options on my hdb5 pls...
especially for my problem read/write...

btw maybe i can use umask options?
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #9 on: August 23, 2008, 06:25:07 am »

Which SOHO version are you using?

Bigpaws
Logged
payne
Member
*
Posts: 14



« Reply #10 on: August 24, 2008, 06:12:17 am »

oh... i forgot to tell, my bad ...
5.8
Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #11 on: August 24, 2008, 07:29:38 am »

Since it is 5.8 things change. You need to install some
packages.

Try this:

http://forum.vectorlinux.com/index.php?topic=4639.0

Bigpaws
Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #12 on: August 24, 2008, 09:06:52 am »

I spotted one error you made in your /etc/fstab file:

Code:
/dev/hdb5   /mnt/hdb5  ntfs defaults rw 0 0

is incorrect syntax and won't set the mount point read/write.  It should read:

Code:
/dev/hdb5   /mnt/hdb5  ntfs defaults,rw 0 0

However. I believe read/write is default behaviour anyway.

ntfs3g has come a long way in the last two years.  You would find life much easier with 5.9.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
payne
Member
*
Posts: 14



« Reply #13 on: August 24, 2008, 09:10:41 pm »

@caitlyn
so i need to put "," after "defaults"
ok thanks, i'll try that

maybe i should change 5.9
but the download is the problem

@bigpaws
i ever use ntsf 3g, but doesnt work with this problem...
what gslapt use for?
« Last Edit: August 24, 2008, 09:14:47 pm by payne » Logged
bigpaws
Vectorian
****
Posts: 1862


« Reply #14 on: August 24, 2008, 10:43:37 pm »

gslapt is for getting applications from the Vector repository.

You need to check that ntfs-3g is installed.

Bigpaws
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!