VectorLinux
October 31, 2014, 06:44:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 080819 netsurf-1.2 [VL59]  (Read 2607 times)
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« on: August 19, 2008, 09:35:00 am »

caitlyn has packaged netsurf-1.2 for VL59

Package: netsurf-1.2-i586-1vl59.tlz
MD5: 8cbde1dbb4208a367ae9f7f6c8a976bc
Package Size: 320 KIB (0.31 MB)
Installed size: 1,100 KIB (1.07 MB)

Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/net/netsurf
Quote
netsurf: netsurf (web browser for RISC OS and UNIX-like platforms including Linux)
netsurf:
netsurf: NetSurf is a free, open source web browser. It is written in C.
netsurf: NetSurf has its own layout and rendering engine entirely written
netsurf: from scratch. It is small and capable of handling many of
netsurf: the web standards in use today.
netsurf:
netsurf:
netsurf: License: GNU General Public Licence, version 2
netsurf: Authors: 
netsurf: Website: http://www.netsurf-browser.org

After testing this package, please take a moment and come back to this thread to let us know how it works for you.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: August 19, 2008, 10:17:25 am »

I get an unmet dependency:

Quote
netsurf: Depends: lcms >= 1.18-i486-1

(we have lcms 1.16 in the repo)
Logged
sparkyhall
Vectorite
***
Posts: 118


« Reply #2 on: August 19, 2008, 11:51:33 am »

Get "Excluding netsurf due to dependency failure" using Gslapt on VL5.9 std.
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #3 on: August 19, 2008, 12:15:47 pm »

I've downgraded lcms on my system and I will rebuild the package.

In the meanwhile go ahead and install lcms 1.16 and lemon 3.6.1.  netsurf will then work correctly.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #4 on: August 19, 2008, 12:35:31 pm »

A corrected package (2vl59) is now in my contrib area.  It should be in testing soon.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #5 on: August 19, 2008, 01:09:13 pm »

caitlyns corrected package is now in testing. Please refresh your sources and try again?

Package: netsurf-1.2-i586-2vl59.tlz
MD5: 23c374bbb9ee3c25fa94a57772f75bf8
Package Size: 320 KIB (0.31 MB)
Installed size: 1,100 KIB (1.07 MB)
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #6 on: August 19, 2008, 01:35:30 pm »

Thanks for the update, caitlyn & exeterdad.
Works just fine.

Only one problem: the exec line in the .desktop file says "opera".
Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #7 on: August 19, 2008, 02:21:26 pm »

ROFL!  I hate that Cheesy
Stay tuned for build 3. I'm sure caitlyn will never be content with that.
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #8 on: August 19, 2008, 03:58:04 pm »

Grrr... I corrected that but must have used the old desktop file in build 2.  Yeah... I'll upload build 3 later tonight.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #9 on: August 20, 2008, 08:47:10 pm »

I've uploaded build 3vl59 with corrected sources and build script.  It should show up in testing shortly.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #10 on: August 21, 2008, 04:43:15 am »

Third times the charm right? This is exactly why we have a testing repo.  We packagers are only human. I/we appreciate all the feedback people. Without it, our "testing" repo remains overflowing, and we are stuck with "dusty" packages in "extra", or no new packages in there at all.

Anyhow, caitlyns new build is in testing. Please refresh your sources and try again?

Package: netsurf-1.2-i586-3vl59.tlz
MD5: 1d4b630384b1ddad8202ea2325966806
Package Size: 320 KIB (0.31 MB)
Installed size: 1,100 KIB (1.07 MB)
« Last Edit: August 21, 2008, 04:47:40 am by exeterdad » Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #11 on: August 21, 2008, 06:27:10 am »

Installed via Glsapt great.

Runs great on my VL5.9 Standard.
The look is comfortable and seems familiar.  I'm using now to post. Not caitlyns fault, but I see javascript text all over the place. Could take some getting used to for me.
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #12 on: August 21, 2008, 08:34:47 am »

It doesn't handle javascript gracefully at all.  LIke Dillo this broswer definitely has limitations but it's a relatively fast alternative for people.  Unfortunately I can only fix package issues, not bugs or deficiencies in the software.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #13 on: August 21, 2008, 10:30:53 am »

This one works fine, and the icon shows up in the menu (as expected).
Great. Thank you!
Logged
kc1di
Packager
Vectorian
****
Posts: 1125


Morse Code Early digital mode. John 3:16


« Reply #14 on: August 21, 2008, 12:18:57 pm »

Runs great here - with limitations of course. Thanks  Smiley
Logged

Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!