VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Firestarter at boot? (Resolved)..........  (Read 4571 times)

deepsix

  • Member
  • *
  • Posts: 19
Firestarter at boot? (Resolved)..........
« on: August 24, 2008, 10:03:21 pm »

Hi all im on vlight 5.9

has anyone succesfully gotten firestarter to start at boot?
if so please tell how.
« Last Edit: August 27, 2008, 11:36:03 am by deepsix »
Logged

deepsix

  • Member
  • *
  • Posts: 19
Re: Firestarter at boot?
« Reply #1 on: August 27, 2008, 11:35:13 am »

Hi all im on vlight 5.9

has anyone succesfully gotten firestarter to start at boot?
if so please tell how.

I finally got it......for those in that need it in the future add the  following to the end of your /etc/rc.d/rc.local, or /etc/rc.d/rc.network file
echo " Starting Firewall"
/usr/local/bin/firestarter --start &>/dev/null
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Firestarter at boot? (Resolved)..........
« Reply #2 on: September 02, 2008, 02:38:29 am »

Hi!
If you get the firestarter package from the repo, you should have the firestarter service in VasmCC>Service>Services.
Enable that for the runlevels you want and disable the "firewall" service.

This way you can use commands such as "service firestarter stop" or "service firestarter status" like for other service and choose which runlevels run it.

Of course it can be done by starting the firestarter binary file itself, like you're doing...
Logged

Jackho

  • Member
  • *
  • Posts: 4
Re: Firestarter at boot? (Resolved)..........
« Reply #3 on: September 17, 2008, 05:48:25 pm »

Dear Deepsix
We noticed that Firestarter would abort on start up when set up as a service. The abort occurred because eth0 was not ready before the service tried to start. So, using brute force and ignorance and your suggestion about modifying rc.network, I added:
service firestarter start
at the end of rc.network; after the "done"
So far in my testing, firestarter is running correctly. Of course this may actually be a bad thing to do. I don't know enough to know that.
Jackho
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Firestarter at boot? (Resolved)..........
« Reply #4 on: September 17, 2008, 08:02:25 pm »

Quote
We noticed that Firestarter would abort on start up when set up as a service. The abort occurred because eth0 was not ready before the service tried to start

I see... I created that firestarter init script and tried to make it as close as possible to the default firewall script.
I wonder what's causing that (I mean, if it's something in the init script or in the firestarter.sh file that the script calls).

I have a few questions, but you would need to delete the line at the end of rc.network and try the "normal" procedure to see what's wrong.

1. I'm assuming you installed the package from the repository (which makes the service available in VasmCC) and that firestarter was run at least once in graphical mode (that creates the /etc/firestarter/firestarter.sh file that is called by the script). Also, that you enabled the firestarter service and disabled the firewall one in VasmCC. True?
2. In my box, the firestarter service is one of the very last to be loaded (before the stuff in rc.local). Is that the case for you?
3. After enabling the service in VasmCC, you should have a file inside /etc/rc.d/rc4.d/ (if you enable it for runlevel 4, for example) that should be exactly the same as the init script /etc/rc.d/init.d/firestarter (in my case the rc4.d file is called S50firestarter). Could you confirm that?
4. I guess after you boot up, "service firestarter status" says it's not running, and "iptables -L" shows no rules. Could you confirm this?
5. Do "service firestarter start" and "service firestarter stop" work correctly? That is, after booting up, does "service firestarter start" make it start even if it has previously aborted during boot?
6. Maybe this has something to do with different firestarter.sh files. This file is created after running firestarter, and I think depends on the few choices that you are asked to do when you first launch it. Could you post the contents of your /etc/firestarter/firestarter.sh?

In my file, those messages come from this bit:
Quote
if [ "$MASK" = "" -a "$1" != "stop" ]; then
        echo "External network device $IF is not ready. Aborting.."
        exit 2
fi

if [ "$NAT" = "on" ]; then
        if [ "$INMASK" = "" -a "$1" != "stop" ]; then
                echo "Internal network device $INIF is not ready. Aborting.."
                exit 3
        fi
fi

I'm way out of my league here, though. I just made the script as a service.  :)
It seems that in your case, enabling the service as boot in VasmCC for a runlevel will lead to it aborting, but if you put the service start at the end of rc.network it doesn't, even if the code is the same  ???

In any case, you've solved it (and you might not have the time or will to do these tests), but I wonder if I made some error packaging it, as the package is now in the extra repository and it might need to be pulled out.

Thanks a lot!
Logged

blurymind

  • Packager
  • Vectorian
  • ****
  • Posts: 1082
Re: Firestarter at boot? (Resolved)..........
« Reply #5 on: September 22, 2008, 03:02:51 am »

i had firestarter on vector way back in the past (vec 5.1 times...) someone at the old forum pm-ed me a init script that worked as  a charm..aah i cant find it ,sorry
Logged
status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/

deepsix

  • Member
  • *
  • Posts: 19
Re: Firestarter at boot? (Resolved)..........
« Reply #6 on: November 15, 2009, 08:57:49 am »

maybe trye to do a
"sleep 5" untill the card comes up?... idk it works perfectly for me the way i suggested...
Logged