Please support VectorLinux!

Author Topic: MySQL Problems - SOLVED  (Read 10998 times)

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: MySQL Problems
« Reply #30 on: September 09, 2008, 01:00:22 pm »
Good news!

I'm actually at another location, but at another laptop also with Vector Linux 5.9 installed, and I've got mysql working!

I followed all the steps you listed and finally got to the mysql> prompt.  Now I have to learn how to use it!

Lost it again when I rebooted, but recovered it again by following the relevant steps.  Now have to set it up so that it is available via VASMCC.

Hopefully, it'll work on the other VL 5.9 machine, when I get back to it on Thursday.

Many thanks for all your dogged help!  I'll wait until I've got the other machine working OK before I mark this 'SOLVED'.


Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: MySQL Problems
« Reply #31 on: September 09, 2008, 02:13:39 pm »
If you want to add a service that can be enabled/disabled to start at boot time via VASM:
cp /usr/share/mysql/mysql.server /etc/rc.d/init.d/mysql
you will now find mysql in the services section in VASM

This works fine, and I can get mysql to work by using VASMCC.

However, now that I'm learning how to use mysql, I see that I have to have '--local-infile=1' (ie activated) if I am conveniently to load pre-written data files into a database.

Which command do I append this to?

If you want to have mysql daemon started at boot automatically (not interactive via VASM):
chmod -x /etc/rc.d/rc.mysqld

Could it be added to rc.mysqld, for example?
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: MySQL Problems
« Reply #32 on: September 09, 2008, 03:13:10 pm »
One of the steps when setting up mysql was to create a my.cnf configuration file in /etc/ (i.e. /etc/my.cnf).  You can add your option to that file in the appropriate places: under the [mysqld] and [mysql] subheads, simply append 'local-infile=1' as the last line, and restart mysql (/etc/rc.d/init.d/mysql restart)

ex)
[mysqld]
.......
local-infile=1

[mysql]
.......
local-infile=1

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: MySQL Problems
« Reply #33 on: September 10, 2008, 12:21:08 am »
Thanks, Newtor!

That's worked great!  Now to sort the other machine tomorrow.
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: MySQL Problems
« Reply #34 on: September 13, 2008, 03:04:16 am »
With many thanks due to Newtor, I've got both VL 5.9 laptops working with mysql!

Learned a lot in the process.
 :)
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard