VectorLinux
September 21, 2014, 01:50:02 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: aMSN 0.97.2 and aMSN Extras  (Read 2487 times)
Masta
Global Moderator
Vectorian
*****
Posts: 725



« on: August 25, 2008, 01:57:19 pm »

Originally, I started this out as two separate packages. The reason for this is because of the size, and users should have a choice if they want the extra stuff in the application or not, among many other reasons we can think of.

Now aMSN has an update release of version 0.97.2. I took the liberty of separating the extra plugins and skins from the package and making those into a separate package again.
 
 If user already has plugins installed and they just want to update their version to the later, they can do so, and not lose their plugins.
  If user wants simply plain aMSN then can have it, and choose to install the extras package at a later time.....
If we could please keep these separated, that would be great.

I only did packages for the 5.9 and they are in testing now. they should work for the 5.8, but I have not tested there.
Logged
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #1 on: October 12, 2008, 11:04:47 am »

I've upgraded a couple of systems and went to the gslapt to grab new packages....
amsn 's RC package is the latest package in the repo. Somehow the package "aMSN 0.97.2" seems to have been removed, which is NEWER than the RC package.


The aMSN 0.97.2 is in my contrib so that it can be re-added to the repo. I have not built a src since I hand built the package using the downloaded source tarball. and used makepkg to roll it up.
Basically it is the source unmodified, just put into directory.
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #2 on: October 12, 2008, 12:35:50 pm »

It's probably an issue of how packages are names since r is later than 0 in ASCII sorting.  Having said that...

Packages in the repo without source make us GPL non-compliant.  I won't put anything in the repo without source.  Further, I won't help maintain a non-GPL compliant repository.  Heck, I refuse to even use non-GPL compliant distros at this point. Please add the source and a build script to your contrib and then I'll move the package.  If that's not acceptable and we're going back to having packages without source please let me know so that I can do what's right for me.

Thanks,
Cait
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #3 on: October 12, 2008, 04:31:17 pm »

I thought that 0.97.2 was later than 0.97.1-rc1?
There is no build script Wink
the only difference from the source is the addition of the directories in the package (/usr/share/) and the .desktop file.

The actual /amsn directory is the actual source. So technically speaking, the source IS included  Grin

What I did was copied that /amsn directory into "~/build/usr/share/" , then backed up into /build and ran makepkg aMSN 0.97.2....tgz  I did this for both packages (amsn, amsn-extras).

I wasn't able to find a source package for the RC either, so I wasn't able to update that and submit it.
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #4 on: October 12, 2008, 07:47:05 pm »

You're right that should be recognized as newer by gslapt/slapt-get unless... it's taking the 0.97.1 as part of the package name and rc1 as the version.  Something is weird here.  I probably can look at it tomorrow and I'll see if I can figure out what is happening.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #5 on: October 13, 2008, 09:41:46 am »

I think the problem is that the newer package is no longer in the repo. I had it moved into 5.9.../testing/net, back when the packages were built.
 I don't recall if glsapt saw it as a newer package or not, I just searched for it, and then marked it to be installed.
 
Now when I search for it, it is not there in the list on glspat, and I can't locate it using web browser @
http://vectorlinux.osuosl.org/veclinux-5.9/
I think it might have been removed, perhaps on accident, when there was a few of us working on the repo at one time -- we were unorganized for a while there.


I will put it back into 5.9/testing/net after I Post here. If it IS in the repo somewhere, then we can safely remove it from testing.

Update
As seen in the screen shot, it DOES see the RC as an upgrade  Undecided
« Last Edit: October 13, 2008, 10:14:11 am by Masta » Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #6 on: October 19, 2008, 09:37:27 pm »

The current version is now in extra and the release candidate is hidden away so that gslapt won't find it.  Thanks for working with me on this.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #7 on: October 21, 2008, 07:22:11 pm »

Good deal, thanks for fixing Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!