VectorLinux
September 23, 2014, 12:05:01 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: VASM - am I doing something wrong?  (Read 1570 times)
boris
Member
*
Posts: 24



WWW
« on: September 08, 2008, 10:42:25 am »

    Kudos and thanks to everybody who invested their time and effort into the release of VL-SOHO 5.9!!

    However, there is something that I can't get to work right - VASM, and in particular, the section where one assigns "inet*" to "eth*".
    The problem in my case is that my computer has 2 interfaces - one is a built-in on the motherboard, the second is a PCI card. I cannot recall the name of the 1-st one, the 2-nd one is Realtek-something. As it happens, I have a dual-boot with WIN-XP, and there, in Windows, the system uses the Realtek interface as default. Obviously I hate the idea of reconnecting the cable each time I switch between the two systems.
    Now when VL-SOHO assigns names to the interfaces, it calls the built-in interface "eth0" and the Realtek interface "eth1". Then it activates "inet1", links it to "eth0", and expects me to configure the network with these default values. Obviously, nothing good happens, since the cable is connected to "eth1", so the default configuration must be changed.
    Well, I open VASM (as root), stop the network and go to the point "change an inet". There I link "inet1" to "eth1", answer the necessary questions about the IP address and NetMask, and wait until the system accepts the new values. Then I try to restart the network, but...
                          ....the dialog window in VASM shows me the "inet1" without any associated interface name and without any IP, netmask or gateway. I still click on it, but naturally the network remains dead.
    Go back to default configuration for simple computer...This links again "inet0" and "eth0", asks the questions about IP, netmask, asks also the question about default gateway. Then I wait until the system accepts the values, and start the network.
     Well, now go to /etc/rc.d/and look at "rc.inet1" and "rc.inet2". Ho-ho, the latter file has 0 length. VASM had not accepted the "eth1" values and had only created a placeholder.
    To make the long story short, I tried to change parameters for "inet1" and "inet2", and each time when I used the "change an inet" menu item, I got the "rc.inet*" descriptor files of length=0. However, when I used the menu item for simple configuration of a standard computer, I got normal descriptor file for "inet1".
      Finally I just copied the "rc.inet1" descriptor to "rc.inet2", edited it by hand, started the network, and from now on my Internet connection works.

     But unfortunately I know that VASM will be of little help if I will need to change this "inet*". And still, maybe I was doing something wrong?

     With best wishes
BNK
Logged

One skeptical donkey used to say: "You may scream 'Honey! Honey!" as loud as you can - it won't make sweet in your mouth..."
bigpaws
Vectorian
****
Posts: 1850


« Reply #1 on: September 08, 2008, 10:55:30 am »

My guess is that ipforwarding has been enable which
maybe trying to setup ICS.

There are a couple of ways of dealing with this. You
could blacklist the unneeded module then the only
ethernet would be the primary NIC card.

Or you add a udev rule to assign the card names.

Bigpaws
Logged
boris
Member
*
Posts: 24



WWW
« Reply #2 on: September 08, 2008, 11:05:24 am »

""Or you add a udev rule to assign the card names.""

    This would be the way of choice for me, if only I would know the answers for 2 questions:
1. Where and what must I edit to introduce the new rules?
2. Will the fact that I activated HAL interfere in any way with the new rules?

Thanks in advance
BNK
Logged

One skeptical donkey used to say: "You may scream 'Honey! Honey!" as loud as you can - it won't make sweet in your mouth..."
newt
Vectorian
****
Posts: 1132



« Reply #3 on: September 08, 2008, 11:30:30 am »

This may help.

1. read here: http://forum.vectorlinux.com/index.php?topic=979.0

2. HAL should not interfere with the udev rules
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!