Please support VectorLinux!

Author Topic: 5.9 Std Firewall  (Read 1436 times)

Jackho

  • Member
  • *
  • Posts: 4
5.9 Std Firewall
« on: September 03, 2008, 04:07:11 pm »
I'm running 5.9 Standard Gold built on Dec-16-07. I have a Dell Dimension 2400 with a 2.4GHz Celeron processor and 256MB memory.
How can I tell if the firewall is running? I log in to the graphical user desktop as a normal user, not root.  From the command prompt (terminal), I enter su and then "service firewall status" and get the answer "rc.firewall is not running". If I enter "iptables -vL" I see what look like firewall rules and packet and bytes counts that change. So I think the firewall is running :-\

If I go to VASMCC->services->services and pick level 4, graphical user interface desktop, the button next to firewall is pushed in.

I'm using the rc.firewall script that came with the 5.9 installation. When I tried VASMCC->network->firewall->New and then tried VASMCC->network-firewall->start, the system locks up. If I delete the rc.firewall and rename rc.firewall.backup to rc.firewall. I can restart my system.

On as side note, how do I search the forum. I put "5.9" +firewall in the search box and every message with the number 5, or the number 9, or the word firewall. I was looking for messages that contained the phrase 5.9 and the work firewall.

Thank you,Jack Homeyer

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: 5.9 Std Firewall
« Reply #1 on: September 03, 2008, 05:00:21 pm »
The search function here is missing alot.

I found it here:

http://forum.vectorlinux.com/index.php?topic=7161.0

Bigpaws

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: 5.9 Std Firewall
« Reply #2 on: September 04, 2008, 02:58:33 am »
I've had the same problems with the VL firewall.
I ended up using firestarter, as in the link above. You might need to install several gnome libs to get firestarter running, but then you can activate it in "Services" and only lauch it to make policy changes or monitor blocked connections.

Jackho

  • Member
  • *
  • Posts: 4
Re: 5.9 Std Firewall
« Reply #3 on: September 05, 2008, 02:35:52 pm »
Thank you, Bigpaws. I followed the link and installed Firestarter. Thanks WCS I got it working with VASMCC.