VectorLinux
December 21, 2014, 02:51:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HP Device manager troubles  (Read 1069 times)
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« on: September 05, 2008, 10:28:54 pm »

After reinstalling Vector formating only root and swap. (I left /home untouched), then doing a slapt-get upgrade. I went to install my printer via the hp device manager or HPLIP-toolbox.
It did find my printer, but then it 1) complained that it couldn't find the right .ppd file for it (so I selected it manually) and then 2) it said it couldn't add the printer queue, so I should restart cups and retry. That didn't work; I could not use the HPLIP toolbox to add my printer.

I attempted some google foo myself and found this...
Quote
This appears to be a problem with UTF-8, hp-toolbox has serious problems with that
Quote
just run hp-toolbox this way and it should work:
env LC_MESSAGES="en_GB.UTF8" env LC_ALL="en_GB.UTF8" /usr/share/hplip/toolbox.py

So I changed Exec line in the hplip.desktop to read...
env LC_MESSAGES="en_GB.UTF8" env LC_ALL="en_GB.UTF8" /usr/share/hplip/toolbox.py
and saved it using Super File manager.

And it worked.

I hope this can help someone else.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!