Please support VectorLinux!

Author Topic: Timidity++ no sound from GUI, but cmd line ok  (Read 3208 times)

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Timidity++ no sound from GUI, but cmd line ok
« on: August 26, 2008, 11:40:50 am »
I installed Timidity++ midi player using gslapt (in VL Gold 5.9)
I now have an extra item in my multimedia category when I right click on the desktop. This brings up a GUI player, which doesnt actually play anything. When I open a midi, it just sits there   >:( .

However, running "timidity test.mid" from a console plays with no problem. ???

Anyone got any ideas ?

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Timidity++ no sound from GUI, but cmd line ok
« Reply #1 on: August 26, 2008, 02:31:32 pm »
Try double clicking on the song you want to hear. For some reason, after loading a song clicking the "play/pause" button doesn't start playing it as you might expect (I know I did). For me, changes in the volume seem to react a little slow. Not a problem though, just put it up high, and change the volume with the normal mixer
Most music on my soundcloud page was arranged in programs running on VL.

mick12345678

  • Vectorite
  • ***
  • Posts: 140
Re: Timidity++ no sound from GUI, but cmd line ok
« Reply #2 on: September 16, 2008, 11:33:22 am »
Thanks - sorry about the delay in replying (I've been away).
Doubling clicking a midi caused it to be played by Mplayer, so I tried "open with" then "browse" and selected Timidity. This  worked - in that the midi started playing - but there was no program interface visible at all so I had to  "kill" the process to stop the midi playing  ???