VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How do you enable auto login??  (Read 4067 times)

trojan

  • Member
  • *
  • Posts: 15
How do you enable auto login??
« on: September 03, 2008, 10:13:32 am »

I'm new to XFCE 4 , and I was wondering how you enable autologin, it doesnt appear to have a login manager like KDE and Gnome.
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: How do you enable auto login??
« Reply #1 on: September 03, 2008, 10:25:01 am »

Logged

trojan

  • Member
  • *
  • Posts: 15
Re: How do you enable auto login??
« Reply #2 on: September 03, 2008, 10:30:42 am »

Theres nothin in the file that it said to edit ???
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: How do you enable auto login??
« Reply #3 on: September 03, 2008, 11:03:52 am »

I read through the link bigpaws suggested the relevant info seems to be this...


Make sure you use KDM as your login manager.
Edit the file /usr/share/config/kdm/kdmrc, change three lines:
AutoLoginEnable=true   
AutoLoginUser=   <-- insert user name
PreselectUser=    <-- insert user name

If you are not finding the appropriate file are you sure you are using the KDM window manager.

I can find it on my system and I have these two items loaded via GSlapt. kdm-small 3.5.5-i586-2vl58 and kdmtheme-Bela 1-noarch-2vl59

To be honest I never chose to switch to the KDM window manager it just seemed to happen when I loaded Amarok. 

Just to be sure I was not sending you on a wild goose chase I did it myself.

Using Super File Manager I followed the path above and opened kdmrc in mousepad.
I removed the # before the AutoLoginEnable=true
then I entered the two other lines below that one, inserting my own user name.
AutoLoginUser=   <-- insert user name
PreselectUser=    <-- insert user name
Then I saved.
Restarted my machine to see what would happen and, baddabing, it worked.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

trojan

  • Member
  • *
  • Posts: 15
Re: How do you enable auto login??
« Reply #4 on: September 03, 2008, 11:19:10 am »

#AutoLoginEnable=true
#AutoLoginUser=colin
#PreselectUser=colin

is that correct should they have a # sign at the beginning?
Logged

trojan

  • Member
  • *
  • Posts: 15
Re: How do you enable auto login??
« Reply #5 on: September 03, 2008, 11:23:06 am »

ha ha ! thanks guys worked without the hash symbole great! :)
Logged

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: How do you enable auto login??
« Reply #6 on: September 14, 2008, 05:29:47 am »

the '#' symbol is (in bash and other shells) used to start a comment. So, lines starting with # are often used as comments in configuration files as well. .
Logged
Most music on my soundcloud page was arranged in programs running on VL.

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: How do you enable auto login??
« Reply #7 on: September 14, 2008, 07:46:57 am »

To be honest I never chose to switch to the KDM window manager it just seemed to happen when I loaded Amarok. 

KDM is a display manager, not a window manager.  It handles the GUI login process only.  It is installed by default on *every* Vector Linux installation.  To use something else you have to make a conscious decision to do so.  It has nothing to do with Amarok.

trojan:  It sounds like your problem is solved.  If so could you please add the word (SOLVED) to the subject title.  That makes life easier for those looking to offer technical support.  Thanks!
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: How do you enable auto login??
« Reply #8 on: September 15, 2008, 01:36:29 pm »

Quote
To use something else you have to make a conscious decision to do so.  It has nothing to do with Amarok.

True, but I see where trojan is coming from.
When you install amarok it pulls kdebase 3.5.9 and I've seen that leading to changes in kdm. I suppose some files in kdebase overwrite the "default" files.

(I don't remember if a fresh 5.9 install has kdebase or the kdm-small package, but either way, iirc upgrading to 3.5.9 overrides your previous kdm settings, and I think the kdmrc file even goes to a different directory altogether).

Of course, it's still kdm, but it might look different after you install kde packages for the first time.
Logged