VectorLinux
April 17, 2014, 12:16:03 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: amarok 1.4.10 failed dependency  (Read 1954 times)
wcs
Packager
Vectorian
****
Posts: 1144


« on: September 12, 2008, 09:13:38 am »

Trying to install the new amarok 1.4.10 in the repo (didn't see an announcement in the boards).
The upgrade fails due to libgpod. It requires 0.6 and we have an older version.

Of course, it runs just fine without upgrading libgpod and probably libgpod < 0.6 works as well, but I haven't tested.
But you get the error message.
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #1 on: September 12, 2008, 11:53:04 am »

I'm going to be doing some repository maintenance this weekend. (What have I gotten myself into  Huh)  I'll check if we have a newer version of libgpod in testing that can be moved.  If not I'll ping the packager.  Amarok is part of the SOHO iso so we must have the dependencies somewhere.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #2 on: September 12, 2008, 02:30:38 pm »

Thanks!
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #3 on: September 16, 2008, 02:29:36 pm »

libgpod-0.6.0 is now in our patches repository for VL 5.9.  That should solve the problem.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #4 on: September 16, 2008, 02:45:45 pm »

Thanks, caitlyn.
Libgpod in turn depends on glib2 >= 2.14.6-i486-4, which is not in the repos.
Isn't glib2 one of those packages that we would be better off not upgrading?

Doesn't look like this amarok package came from a clean box.
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #5 on: September 16, 2008, 02:51:58 pm »

You're correct.  I'll try to rebuild the libgpod package and/or ping the builder of the amarok package to rebuild it.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #6 on: September 20, 2008, 10:36:38 am »

rbistofi built a new libgpod-0.6.0 package for VL 5.9 that is now in testing.  That package does solve the problem AFAIK.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #7 on: September 20, 2008, 11:13:08 am »

Installing fine now.
Thank you!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!