Please support VectorLinux!

Author Topic: 080923 opera-9.52 [VL 5.9]  (Read 1775 times)

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
080923 opera-9.52 [VL 5.9]
« on: September 22, 2008, 09:38:42 pm »
Vector has packaged Opera 9.52 for VL 5.9.  Please note that this package is already in our patches repository, not testing.

Package: opera-9.52-i386-1vl59.tlz
MD5: 9ed3def7deb0eaac6ab9933d2bbfe0ea
Package Size: 5.841MB
Installed Size: 19.390 MB

Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/patches/x-apps/opera

Code: [Select]
opera-en: Opera (The fastest browser in the world)
opera-en:
opera-en: The most full-featured Internet power tool on the market, Opera
opera-en: includes  pop-up blocking, tabbed browsing, integrated searches
opera-en: E-mail, RSS Newsfeeds and IRC chat.
opera-en:
opera-en:
opera-en:                       http://vectorlinux.com
opera-en:
opera-en:
opera-en: Packager Vector

After testing this package, please take a moment and come back to this thread to let us know how it works for you.

« Last Edit: September 23, 2008, 08:01:41 am by caitlyn »
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: 080923 opera-9.52 [VL 5.9]
« Reply #1 on: September 24, 2008, 02:12:18 pm »
Errr... shouldn't Opera go in /net/ and not in /x-apps/?
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

vector

  • Administrator
  • Vectorite
  • *****
  • Posts: 479
Re: 080923 opera-9.52 [VL 5.9]
« Reply #2 on: September 24, 2008, 05:23:38 pm »
good question Joe. I pondered that building the package but papa slack puts firefox mozilla et all into X-apps so I went with that. Looks like slackware keeps the command line type net apps in /net anything that requires the Xorg server goes in X-apps.

Cheers,
Vec

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: 080923 opera-9.52 [VL 5.9]
« Reply #3 on: September 24, 2008, 06:00:50 pm »
I know, but back when I started packaging SeaMonkey (before inconnu started), we discussed this and the concensus was to go with /net/. I'm just saying we need to be consistent with ourselves... (LOL, that came out somewhat funny... ;D)

Anyway, dumping EVERYTHING GUI into x-apps is pretty messy, IMHO.
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080923 opera-9.52 [VL 5.9]
« Reply #4 on: September 24, 2008, 06:20:03 pm »
I'm with Joe on this one.  If Slack was perfect we'd all be running Slack and there would be no need for Vector.  I prefer Vector :)

Obviously I'll follow whatever instructions y'all give me... at least until exeterdad gets back to doing it.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: 080923 opera-9.52 [VL 5.9]
« Reply #5 on: September 25, 2008, 05:17:16 am »
I saw that vlnvidia is one of it dependency....is that correct?

Quote
PACKAGE REQUIRED:  bash >= 3.1.017,libX11 >= 1.1.3,libXext >= 1.0.3,libSM >= 1.0.3,libICE >= 1.0.4,zlib >= 1.2.3,cxxlibs >= 6.0.8,gcc >= 4.1.2,libmng >= 1.0.9,libjpeg >= 6b,libpng >= 1.2.29,mesa >= 7.0.2,libXmu >= 1.0.3,libXi >= 1.1.3,libXrender >= 0.9.4,libXrandr >= 1.2.2,libXcursor >= 1.1.9,libXinerama >= 1.0.2,libXft >= 2.1.12,freetype >= 2.3.7,fontconfig >= 2.4.2,libxcb >= 1.0,libXau >= 1.0.3,lcms >= 1.16,vlnvidia >= 5.9,libXt >= 1.0.5,libXfixes >= 4.0.3,expat >= 2.0.1,libXdmcp >= 1.0.2

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080923 opera-9.52 [VL 5.9]
« Reply #6 on: September 25, 2008, 10:09:14 am »
No, it's not correct.  I'll let Vector know we have a problem with this package.  Expect a new build soon.

UPDATE:  The package now in testing has a corrected slack-required file.  The package build number hasn't changed since everything else is the same.  It should work properly now regardless of the video chipset used.
« Last Edit: September 25, 2008, 11:54:29 am by caitlyn »
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

hata_ph

  • Moderator
  • Vectorian
  • *****
  • Posts: 3261
  • -- Just being myself --
Re: 080923 opera-9.52 [VL 5.9]
« Reply #7 on: September 26, 2008, 07:16:32 am »
The vlnvidia dependency have been removed. Thanks.