VectorLinux
October 01, 2014, 02:12:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 080925 htop-0.8.1 [VL 5.9]  (Read 2692 times)
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« on: September 25, 2008, 12:24:48 pm »

toothandnail has packaged the latest version of htop for VL 5.9 and VL 5.9.1.

Package: htop-0.8.1-i586-1vl59.tlz
MD5: 89abd651b1eaa926ff9599897040e2c0
Package Size: 54K
Installed Size: 160K

Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/base-apps/htop

Code:
htop: htop (an interactive process viewer)
htop:
htop: htop is an interactive process viewer like top. It displays system
htop: processes, and allows them to be killed or reniced. Unlike top, it
htop: is capable of killing multiple processes at once.
htop:
htop:
htop:
htop: License: GPL
htop: Authors: Hisham H. Muhammad
htop: Website: http://htop.sourceforge.net/

After testing this package, please take a moment and come back to this thread to let us know how it works for you.
« Last Edit: September 25, 2008, 12:28:08 pm by caitlyn » Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: September 25, 2008, 02:27:49 pm »

Error in gslapt.
htop depends on ncurses >= 5.6-i486-3 (not in the repo, so far as I can see).
Should be rebuilt against 5.6-i486-2.
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #2 on: September 25, 2008, 02:55:04 pm »

Error in gslapt.
htop depends on ncurses >= 5.6-i486-3 (not in the repo, so far as I can see).
I can confirm this, same happened on 5.9.1 SOHO.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #3 on: September 25, 2008, 03:05:20 pm »

I've let the packager know.  Hopefully we'll have a replacement package soon.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #4 on: September 25, 2008, 03:18:38 pm »

Thanks. I should add that it does work after forcing install.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #5 on: September 26, 2008, 05:17:42 pm »

A revised package with a corrected dependency list has been posted.  Please do try installing this version of htop again.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #6 on: September 26, 2008, 07:46:34 pm »

Working fine.
Thank you.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #7 on: September 26, 2008, 08:09:54 pm »

A potential issue concerns the .desktop file calling xterm.
This implies that the user has xterm installed. If he/she doesn't, it won't start from the menu (although xterm doesn't feature as a dependency):
Code:
Terminal=false
Exec=xterm -e htop

The previous version instead had:
Code:
Terminal=true
Exec=htop

Which, I guess, calls the "default terminal", making it a better option.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #8 on: September 27, 2008, 08:01:20 am »

A potential issue concerns the .desktop file calling xterm.
This implies that the user has xterm installed. If he/she doesn't, it won't start from the menu (although xterm doesn't feature as a dependency):
Code:
Terminal=false
Exec=xterm -e htop

The previous version instead had:
Code:
Terminal=true
Exec=htop

Which, I guess, calls the "default terminal", making it a better option.

Ahh. I changed that after hitting a problem with one terminal - think it was KDE Konsole. It wouldn't work from the menu. On the other hand, Xterm is almost always installed, which makes it independent of the DE. Should have added a dep to xterm though. I'll fix that and upload a revised version....

Thanks for picking that up - forgot about the extra dep.

paul.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #9 on: September 27, 2008, 04:39:06 pm »

I see. It makes perfect sense.
You had actually made clear that you had modified the .desktop file in the Packagers board, but I only saw it now.

I guess it would be possible to use an environment variable in the .desktop file, maybe:
Code:
Exec=$TERM htop

In my system, typing that in a console opens htop in xterm.
(Even though I'm using xfce, $TERM is set to xterm and not to the xfce Terminal)

I suppose that would open it in whatever the user decided to be the "default", without adding a mandatory dependency for a particular terminal.

(sorry for nipicking... after all, it is probably the case that almost everyone will have xterm installed)
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #10 on: September 27, 2008, 05:10:23 pm »

Just found a problem with my own solution.
If I set $TERM to the xfce Terminal, "$TERM htop" doesn't work, because it needs -x to execute a command.

xterm doesn't need this (and the option is actually -e)

So, not really a general solution for several terminals. Oh, well...
Logged
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #11 on: September 29, 2008, 09:20:46 am »

A revised package which addresses the terminal issue has been posted.

Package: htop-0.8.1-i586-2vl59.tlz
MD5: 5feb156d1e1da4aea72e3131e9e71f2f

Please let us know how the new package works for you.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #12 on: October 01, 2008, 06:18:25 pm »

I haven't found any problems on my 5.9 Deluxe laptop.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #13 on: October 01, 2008, 11:29:18 pm »

Working fine. Thanks!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!