VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Openoffice 3.0 is crashing in VectorLinux 5.9 Light  (Read 4873 times)

kultex

  • Member
  • *
  • Posts: 34
Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« on: October 21, 2008, 10:43:12 am »

I was using the german version of Openoffice 2.3.1 in VectorLinux 5.9 Light - installed with the help of "rpm2tgz" - it worked without any problems.
I installed now Openoffice 3.0 the same way, but it crashes all the time - what can be the problem? missing packages? The initial menue starts without any problems, but as soon as I choose writer or calc it crashes
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #1 on: October 21, 2008, 11:15:43 am »

can you try the OO package in the 5.9 repo and let us know if it works better for you?
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #2 on: October 21, 2008, 11:16:25 am »

rpm2tgz has the potential to cause various problems.  My suggestion would be to simply install v3.0 from the VL repo instead.

HTH!

edit:
darn!! too slow ;D
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #3 on: October 21, 2008, 11:38:16 am »

The initial menue starts without any problems, but as soon as I choose writer or calc it crashes

Try launching Calc from the terminal to see what error messages are produced. The command is "scalc".
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

kultex

  • Member
  • *
  • Posts: 34
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #4 on: October 22, 2008, 01:34:27 am »

scalc is not known - swriter just hangs - if I start soffice and then try to start calc it tells "terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'"

it would be nice to get this version running, because of all the language packages ....
Logged

kultex

  • Member
  • *
  • Posts: 34
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #5 on: October 22, 2008, 07:26:48 am »

I deinstalled all oo packages and installed 3.0 from the VL repo

same thing than before
« Last Edit: October 22, 2008, 11:09:34 am by kultex »
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #6 on: October 22, 2008, 11:40:16 am »

I just installed OpenOffice 3.0 from the repo into a fresh build opf Vector Linux Light to see if I could replicate the problem.  It works perfectly well here.  So... I have to assume either you installed something else that conflicts with OpenOffice or else you are missing something OpenOffice depends on.  Since OpenOffice isn't supposed to have any dependencies (no slack-required file) the latter is unlikely but possible.  A third possibility is that you somehow accidentally deleted part of the core VL Light system that OOO needs.

Let's start by looking for conflicts.  Please post the output of:

ls /var/log/packages

so we can see what's installed on your system.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

kultex

  • Member
  • *
  • Posts: 34
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #7 on: October 22, 2008, 01:03:08 pm »

I am going to install VL-light tomorrow new
Logged

kultex

  • Member
  • *
  • Posts: 34
Re: Openoffice 3.0 is crashing in VectorLinux 5.9 Light
« Reply #8 on: October 29, 2008, 03:18:03 pm »

sorry - took some more time!

sorry - everything is fine - v3.0 from the VL works fine and also the german RPM openoffice with rpm2tgz.

Only the the install installer package with JRE makes the problems ..... no dea why I took this - I think it was to early in the morning ....
Logged