VectorLinux
July 29, 2014, 04:19:06 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: vpackager question...  (Read 862 times)
jc8670
Member
*
Posts: 2


« on: October 03, 2008, 12:36:01 am »

Hello,

I tried making a package of starfighter (a game) using vpackager and it told me that it couldn't process the package and to install myself. I did that and i successfully installed it and ran it. However, why didn't vpackager work?

1. I was using the source tar ball.
2. I made a description incase it required it.
3. Nothing is wrong with the source, since i compiled it.
4. I tried multiple sources of programs, all fail with the same error

Can anyone give me any pointers on what I am missing?

I am running VL 5.9 Std Ed. (xfce 4). On an AMD thunderbird, 512 MB DDR.

Thank you very much.
« Last Edit: October 03, 2008, 12:40:02 am by jc8670 » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3178



« Reply #1 on: October 03, 2008, 04:10:58 am »

which vpackager version is this? you can find the latest at the good page. The link is in my signature. Let me know if that one gives you the same result

_EDIT_
Never mind the above suggestion. The newest package will give you the exact same results. There is a couple of reasons for this
The very first problem here is that the source tarball is named in a non-standard manner.
The tarball is named startfighter-1.1-1.tar.gz.
so vpackager thinks the app name is really "starfighter-1.1" and that it is version "1"
when extracted, the resulting directory is starfighter-1.1 (you can see the difference here)

vpackager is designed to work with tarballs named in the standard name shceme (name-version.tar.gz/bz2) assuming the developer disn't screw up by tar-ing a directory with another name in there.

Secondly is has no configure script
vpackager can't handle this type of source code yet.
« Last Edit: October 03, 2008, 05:02:33 am by M0E-lnx » Logged

jc8670
Member
*
Posts: 2


« Reply #2 on: October 03, 2008, 11:14:12 am »

ah, i see. That explains it.

thank you for your time.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!