Please support VectorLinux!

Author Topic: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]  (Read 6454 times)

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #15 on: October 03, 2008, 07:04:21 am »
I only tried it by using -UILocale and it worked fine:
Code: [Select]
firefox -UILocale pt-PT -contentLocale PT
You can also try the general.useragent.locale variable in about:config.

Perhaps LANG is not having an effect due to the  intl.locale.matchOS variable?
I would think that should say "true", but is instead set to "false" here.

That is correct I think. Firefox does not listen to $LANG by default iirc, we would need to fix that in the ff package.
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #16 on: October 03, 2008, 09:35:09 am »
In previous builds Exeterdad claimed that so long as LANG was set you were good to go.

Quote
Firefox does not listen to $LANG by default iirc, we would need to fix that in the ff package.

That's probably what he did and I do think it's something we should do to make localization easier for our users, at least in future builds.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #17 on: October 03, 2008, 02:15:11 pm »
I Think if his scripts were used to build the new FF packages this would be done by them.

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #18 on: October 03, 2008, 04:15:45 pm »
uel:  I think you're right.  Vector used his own script.  Perhaps we can go back to the exeterdad script in the future.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #19 on: October 06, 2008, 01:28:18 pm »
Firefox 3.0.3 is now in patches and the language packs are now in extra.  We've had complaints about security patches sitting in testing too long and I agree.  If someone needs help enabling a language pack we'll have to deal with that in the forum.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

overthere

  • Vectorian
  • ****
  • Posts: 1311
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #20 on: October 26, 2008, 11:13:50 pm »
Hi
while updating my vl5.9 std install via gslapt, I found that firefox gives a dependency warning regarding gnome-vfs2.1.8.1 and the option to proceed...I recall reading a thread about abi 2.6.2 and this file not being an issue with install... so I decided to install anyway. I am using it now but thought mention may be of value..perhaps I should have heeded the warning?
Everything Is Relative

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2876
    • The Linux Works
Re: 080927 mozilla-firefox-3.0.3 and all language packs [VL 5.9]
« Reply #21 on: October 27, 2008, 11:27:20 am »
Thanks for making us aware of the dependency issue,  It should work fine with the older version of gnome-vfs so you should have no problems at all.  The slack-required file needs to be changed.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1