VectorLinux
November 01, 2014, 01:19:50 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: My desktop has been gone... [solved]  (Read 3473 times)
Asound
Member
*
Posts: 19


« on: October 02, 2008, 12:22:32 pm »

Hello again,

Iam having an really stupid problem. Iam using Vectorlinux 5.9 and always have running Compiz-Fusion. I also disabled xfce for managing my desktop, so that Compiz-Fusion does it.
My problem is, whenever I log in into my normal user-account Iam just having an black sceen, nothing appears.
I think it happened because Iam using the cube from compiz and have been on desktop 2, 3, or 4, that I thinks are just copys from desktop one. And than i shutted down the system while i have been at one of these desktops and not on the original desktop from Xfce. Well and Xfce saved the sessions because i activated the function...
When i try to run Compiz-Fusion with the command "fusion-icon" it only appears the backround image (i can open the console with an keystroke, but all windows doesnt have any window-decorator, even when i opened compiz)

Hope anybody can help, also hope its the right section!
« Last Edit: October 03, 2008, 07:25:18 am by Asound » Logged
Masta
Global Moderator
Vectorian
*****
Posts: 725



« Reply #1 on: October 02, 2008, 04:06:10 pm »

You can try renaming or removing your /home/user-name/.config/compiz/compizconfig/config file, see if that gets your xfce back. to a usable desktop.

I don't think it matters which desktop you use before logging out, but somewhere something seemed to have gone wrong somehow. Maybe the following can help with that, but only if the above works.


It seems that you may not have extensions enabled in your xorg.conf. you may want to check that.

Next you might want to edit your /etc/profile.d/vasm.sh and find the line that that says
Code:
export XLIB_SKIP_ARGB_VISUALS=1
and comment it out so it looks like this:
Code:
#export XLIB_SKIP_ARGB_VISUALS=1
this should help the window decoration issue if you are using Nvidia.
Logged
Asound
Member
*
Posts: 19


« Reply #2 on: October 03, 2008, 07:11:05 am »

I have removed the config file but that hasnt changed anything, compiz was still configured how I had configured it.

Editing the vasm.sh helped! Now Iam having window decorator when i run compiz-fusion. Thanks!

Now the only thing that is missing is the taskbar.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #3 on: October 03, 2008, 07:16:52 am »

Hit alt+f2 and run xfce4-panel, save the session again to keep the changes.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Asound
Member
*
Posts: 19


« Reply #4 on: October 03, 2008, 07:24:59 am »

Thank you sooo much! You guys are so great! Everythings working!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!