VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: LXDE crashing  (Read 2343 times)

shankargopal

  • Member
  • *
  • Posts: 2
LXDE crashing
« on: October 05, 2008, 06:34:44 am »

I'm a totally new VL user, having just installed VL 5.9 Light today (my workhorse system for the last three years has been Puppy Linux on a flash drive; I'm installing VL at the moment to see if it runs faster than Puppy 3.01 on an old system that I have).  I had some network problems which I attempted to fix through vasmCC - eventually they were fixed through vasm.  But something seems to have happened to LXDE as I was using vasmCC.  At one point I used netconf in vasmCC to start a connection, and suddenly LXDE crashed and I was returned to the xdm (I assume it's xdm??) login screen.  Now, if I try to login either as root or as my user, LXDE crashes every time - it flashes the bottom bar on the screen and then returns to the login.  Fluxbox, on the other hand, works fine. 

My system specs are as follows:
AMD Sempron
256 MB RAM with a 590 meg swap partition
VL on a hard drive partition with 3.6 G of RAM, currently full to about 2.6 G
SiS graphics card (due to Xorg problems that I have had in Puppy, I have changed /etc/X11/xorg.conf in VL to specify the card driver as 'vesa' instead of 'sis')

Any idea how I can get LXDE to function again?  I find this a complete mystery.  Have not yet had the chance to try starting LXDE from the command line.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4132
Re: LXDE crashing
« Reply #1 on: October 05, 2008, 07:11:35 am »

LXDE is still a young project. I remember having problems where the network applet on the panel caused crashes.

You may try creating a new user and logging in as such. If it crashes as well, I'd suspect a newly installed app, especially anything with an applet on the panel.
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: LXDE crashing
« Reply #2 on: October 05, 2008, 07:12:18 am »

When you boot next time, boot to "linux-tui", login as yourself in the console and type "startx". What error messages do you get in the console?
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

shankargopal

  • Member
  • *
  • Posts: 2
Re: LXDE crashing
« Reply #3 on: October 08, 2008, 01:07:42 am »

Thanks a lot for such quick replies, and sorry to take so long to get back - in between I could not access the concerned computer.  Oddly enough, though, now there seems to be no problem  ???.  I did not use the linux-tui method, but instead used vasm to allow me to boot into text mode, and then edited my .xinitrc to run startlxde to test it out.  To my surprise it seems to be working.  In addition, XFCE - which I had installed from the repo - also now seems to be working after some initial troubles. 

Thanks again and will let you all know if I face further LXDE issues...
Logged