VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: Driver for Agere WinModem...[SOLVED]  (Read 9154 times)

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Driver for Agere WinModem...[SOLVED]
« on: October 08, 2008, 05:30:34 pm »

Hi all,

I'm seriously in trouble now...

I had to re-install the System VL-5.9-std on my Laptop Dell Inspiron 2500 because of this ISSUE.
Now I can't install the driver for an Agere Winmodem, which is correctly detected, anymore.
I know, I have the right driver and I have the instructions what to do...it worked previously on this machine.
I attached the terminal outputs for "lspc" , "make clean" , "make all" , "InstallModemInstructions" and I would like to provide whatever is needed to fix this issue.
Without Internet connection the whole effort to abandon Windows turns out to be futile!

 ???   ???   :o   ???   ???
« Last Edit: November 25, 2008, 09:15:43 am by Cariboo »
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Driver for Agere WinModem...
« Reply #1 on: October 09, 2008, 09:07:04 am »

"make all" error messges show that there ar a number of files missing that are required to do the compiling. So either:
1) you forgot the ./configure stage. Did you do that?
1) you are not in the right directory when doing make
2) you have untarred the package to wrong directories
3) the package you donwloaded is invalid

Have a close look at those error messages and look for the files that are missing. You can do this with an "updatedb" then "locate filename" command.

Good luck
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #2 on: October 09, 2008, 09:35:19 am »

"make all" error messges show that there are a number of files missing that are required to do the compiling. So either:
1) you forgot the ./configure stage. Did you do that?
No, I didn't...I can't remember where and when this should have happened  ???
Please, can you tell me when I have to do that?

Re. 2) I'm sure I worked in the right directory ( as always I used /tmp)
Re. 3) The package is the same which once worked.
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Driver for Agere WinModem...
« Reply #3 on: October 09, 2008, 03:06:48 pm »

You do it before anything else - you can redo the steps, no harm done.

1) navigate to directory where you unpacked the source
2) ./configure
3) make
4) become root (su) then "make install"
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Driver for Agere WinModem...
« Reply #4 on: October 09, 2008, 03:24:54 pm »

This seems like one of those packages that cannot be configured - at least, not the normal way (i.e. ./configure).  I looked at the INSTALL file contained within the driver package and the instructions vary slightly from your InstallModem.txt file.  It indicates that you should:

unpack the archive
as user run: make all
as root run: make install
(it does not mention running make clean)

If you cannot configure the package as indicated by lagagnon then remove your unpacked directory, unpack the archive again, and try the steps mentioned above to see if the outcome is any better than before.
Logged

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #5 on: October 09, 2008, 06:28:38 pm »

You do it before anything else - you can redo the steps, no harm done.
1) navigate to directory where you unpacked the source
2) ./configure
........................
I think newtor is right....
running the command ./config gives prompt:
bash: ./configure: No such file or directory

Logged
Life is full of setbacks; Success is measured by the way you deal with them!

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #6 on: October 09, 2008, 11:17:32 pm »

......unpack the archive
as user run: make all
as root run: make install.
If you cannot configure the package as indicated by lagagnon then remove your unpacked directory, unpack the archive again, and try the steps mentioned above to see if the outcome is any better than before.
I did unpack again and ran the commands without 'make clean' and got exactly the same error output as I already attached earlier in the 'Make-all.txt' file.

What I do next, I try a new start and get the driver package again! 8)
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #7 on: October 09, 2008, 11:34:37 pm »

I downloaded the driver again and proceeded as described and, again the same output from 'make all'
Can it be that it has something to do with the special kernel configuration I had to make because ofTHIS 
 ???     ???
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Driver for Agere WinModem...
« Reply #8 on: October 09, 2008, 11:49:43 pm »

I tested making the package on a (relatively speaking) stock VL 5.9 Standard with kernel 2.6.22.14 and everything went smooth.  I did not install the driver since I don't have the hardware, but the 'make all' process went as expected.

I'm guessing that, as you mentioned, it must have _something_ to do with your newer kernel (2.6.22.19).... but, what? I don't know.  Also, I just noticed, that I was using the version posted in your InstallModem.txt file: martian-full-20080407.tar.gz

Perhaps it's worth trying to use the older 20080407 package as a test???

Sorry I couldn't be more help.
Logged

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #9 on: October 10, 2008, 09:09:00 am »

I tried the older version...same problem....

I'm going to make a new installation  from scratch....
maybe something went wrong with the kernel configuration...
 :(
@uelsk8s
I have a question before I start again:
I wonder why I had to get a new kernel for THIS in the first place?
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #10 on: October 12, 2008, 01:26:56 pm »

Hi All,
I'm not sure if this will help VectorLinux Dial-Up experts to figure out how to fix this issue.
I found out that Puppy Linux had no difficulties to detect the modem. They also have the right drivers handy and the dialer had no difficulties to configure.
Here are some details of the installation:
1) Puppy 4.1 Retro which has the 2.6.21.7 kernel
2) gkdial-libs-1.2.pet
3) gkdial-1.5.14patched.pet

The procedure war really easy...
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Driver for Agere WinModem...
« Reply #11 on: October 12, 2008, 02:06:27 pm »

Winmodem drivers are very much kernel specific.  They only work in the version of the kernel they were compiled for and they do NOT work with custom kernels as a general rule.  I always tell people that WinModems are NOT supported in Linux, period.  There are drivers, they work sometimes, and they lock you into a kernel, very often one with security vulnerabilities until if and when an update driver is available.  Most of the major Linux distributions simply treat them as unsupported and don't mess with them.

My advice may sound harsh but it's probably realistic.  If you have a configuration which works in another distro and you're happy with it then stick with that.  I don't expect Vector Linux will ever properly support or even every try to properly support your WInmodem.  Even if VL gets it right today the minute a kernel patch for security is offered it will break.  That's why there's no support for your modem in most distros. 

My real advice is to get a PCMCIA hardware modem that will be supported under Linux and that won't steal CPU cycles to run a software modem.  They're $10 and under on eBay.  Forget there even is a modem built into your laptop.  My laptop has a Winmodem, too.  Back when I still used dial-up I ignored that it even existed.  Better to have my system secure and use a PCMCIA slot than to have a system with known vulnerabilities just to keep the modem going.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #12 on: October 12, 2008, 04:04:10 pm »

Thank you very much, caitlyn,
I appreciate your honest comment and, because I struggle with WinModems since I began using Linux, I totally agree, it's always like messing around. This is my first Laptop and I never thought I could get a Linux supported hardware modem for it. You mentioned to "use a PCMCIA slot"...I first have to figure out what it means.
Thanks for your advice, I'll keep you posted.
 :)
Logged
Life is full of setbacks; Success is measured by the way you deal with them!

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Driver for Agere WinModem...
« Reply #13 on: October 12, 2008, 04:23:19 pm »

A PCMICA slot is on the side of most laptops.  It's where you insert credit card sized devices.  Most laptops made in the past 10 years or so have two such slots.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Cariboo

  • Vectorite
  • ***
  • Posts: 289
Re: Driver for Agere WinModem...
« Reply #14 on: October 12, 2008, 05:14:45 pm »

A PCMICA slot is on the side of most laptops.  It's where you insert credit card sized devices.  Most laptops made in the past 10 years or so have two such slots.
I see it..There are two of those...Thanks caitlyn, this saves me some googleing time  ;D
Now I need only to find the right item! "google  ::)  google"
Logged
Life is full of setbacks; Success is measured by the way you deal with them!
Pages: [1] 2