VectorLinux
April 24, 2014, 08:24:35 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Keepassx request  (Read 3801 times)
curtdodds
Member
*
Posts: 17


« on: October 12, 2008, 05:30:40 pm »

The only package I need to make vector linux work for me.
It is a cross platform password keeper (database).
http://www.keepassx.org/

I have tried various methods of installing it.
Slacky  has a version .33 and I've downloaded the source.
In all cases there are missing libs or wrong version conflicts.
An officially supported version should overcome those problems.
Logged
Monty67
Member
*
Posts: 66



« Reply #1 on: November 11, 2008, 07:14:25 am »

Here here I second this request. Excellent program that allows easy transfer of passwords from one machine to another.
Logged

Strange women lying in ponds distributing swords is no basis for a system of government.
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #2 on: November 14, 2008, 05:58:06 pm »

I just built this for 6.0, and I am setting up a chroot for 5.9 to see if I can get it built there also.

I will keep you posted.

Uelsk8s
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #3 on: November 15, 2008, 01:59:16 pm »

Uelsk8s' 5.9 package will be available in the repo later this afternoon Smiley
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Monty67
Member
*
Posts: 66



« Reply #4 on: November 17, 2008, 06:46:02 am »

NIIIIIICEEEEE!!!!!!!!!!!!!!!!!!!!


Well done uelsk8s  Grin Grin Grin Grin Grin Grin Grin

thx
Logged

Strange women lying in ponds distributing swords is no basis for a system of government.
Monty67
Member
*
Posts: 66



« Reply #5 on: November 17, 2008, 07:15:02 am »

 Sad

Quote
root:# slapt-get --install keepassx
Reading Package Lists... Done
No such package: keepassx
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Has it been updated/uploaded yet?

If not I can wait. when it is uploaded would you be so kind to post it here. thx.
Logged

Strange women lying in ponds distributing swords is no basis for a system of government.
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #6 on: November 17, 2008, 10:03:41 am »

it's there:

http://vectorlinux.osuosl.org/veclinux-5.9/testing/x-apps/keepassx-0.3.4_2.6.26.8-i586-1vl59.tlz
Logged

Most music on my soundcloud page was arranged in programs running on VL.
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #7 on: November 17, 2008, 10:37:50 am »

You need to enable the testing repository to install keepassx and it's dependencies.  All new packages go through the testing processs.  Just be sure to disable testing when you're done.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Monty67
Member
*
Posts: 66



« Reply #8 on: November 17, 2008, 05:19:25 pm »

Thanks Headacher

I d/l the package directly and it worked perfectly. I'm currently setting up my Gmail manager via Firefox add on, and whole host of other things.

Caitlyn

thanks for the info I have already removed the testing branch now that things are working.

.....and thanks to all involved.
Logged

Strange women lying in ponds distributing swords is no basis for a system of government.
curtdodds
Member
*
Posts: 17


« Reply #9 on: December 10, 2008, 09:19:36 pm »

What a pleasant surprise!
I installed keepassx from the 6.0 repo today.
Working perfectly.

Thank You Very Much!
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #10 on: December 29, 2008, 06:21:32 pm »

I tried to install KeepassX today but Gslapt says there's a missing dependency: glib2 needs to be > 2.16.6 but the installed version is 2.12.12 and there's no upgrade in the reps. I've got patches and testing enabled and have updated, even tried a different source. The strange thing is... I'm sure I installed it on another machine a while back without problems. Any ideas?

Thanks
Andy
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #11 on: December 29, 2008, 07:11:18 pm »

The newer version of glib was pulled from the VL 5.9 repo.  I don't know who did that and I don't know why.  If you installed it on another machine you still have it in your /home/ftp/pub/veclinux/packages directory.  You can transfer it from that machine to your new machine and install it:

installpkg <package name>

I don't have a VL 5.9 machine any more (running 6.0 exclusively now) and I haven't found the source or build scripts for that version in any case.  I try to avoid mucking about with core libraries -- my skills aren't strong enough that deep under the hood for me to trust myself.

Next time I chat with one of the core developers I'll mention the glib situation.  No promises on the outcome, though.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #12 on: December 30, 2008, 02:19:18 am »

Thanks Caitlyn, at least I know I'n not going mad! Unfortunatley I don't have access to the other installation any more as the hard drive failed, so I guess I'll have to wait and hope it gets put back in the reps. Strange it was pulled - it breaks the gftp upgrade as well I've just found out.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #13 on: December 30, 2008, 09:39:29 am »

glib2 is in the unstable repo.
IMO glib2 should never be upgraded between releases.
If it works for you without breaking anything else, then you need to add teh unstable repo to upgrade it.
IMO Anything that needs glib2 should be moved to the unstable repo also.
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #14 on: December 30, 2008, 10:40:09 am »

Uel:  Thanks for jumping in on this.  I'm not at all sure that keepassx needs the updated glib2.  IMHO the package probably should be rebuilt.  I'll ping the packager.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!