VectorLinux
April 24, 2014, 06:20:53 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: CD mounting not working  (Read 2214 times)
quoque
Member
*
Posts: 7


« on: October 11, 2008, 11:40:46 pm »

It seems to me this should be easy, but I can't mount a CD, every disc I try it says "Feature only available with HAL", I did pick VL-hot during the installation but surely either would work.

I am using SOHO 5.9, KDE window manager.
Logged
bigpaws
Vectorian
****
Posts: 1834


« Reply #1 on: October 12, 2008, 05:02:37 am »

VL-Hot is for mounting USB keys and such. Not
for mounting cdrom or DVD media.

You should be able to switch it with VASM.

HTH

Bigpaws
Logged
quoque
Member
*
Posts: 7


« Reply #2 on: October 12, 2008, 07:26:12 am »

So do I need to use HAL to get the CD-ROM to mount?  I cant even mount it manually, though it SOHO knows I have a CD ROM.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #3 on: October 12, 2008, 09:29:29 am »

You shouldn't have to use HAL to mount cd's, so far as I know.
What happens when you try "mount /dev/hdc /mnt/cdrom" ?
(I'm asssuming the device is hdc, though that might not be the case)
Logged
bigpaws
Vectorian
****
Posts: 1834


« Reply #4 on: October 12, 2008, 10:40:25 am »

Unless you changed /etc/fstab to allow users to mount the
cdrom you may need to be root.

Bigpaws
Logged
quoque
Member
*
Posts: 7


« Reply #5 on: October 12, 2008, 01:16:50 pm »

O.k. I am completely out of my depth, there is an entry in /etc/fstab :

/dev/cdrom    /mnt/cdrom  iso9660 defaults,noauto,ro,user 0 0

Which I assume is correct, it seems the the CD drive is /dev/hdc from the symbolic links in /dev :

lrwxrwxrwx 1 root cdrom 3 2008-10-12 17:08 /dev/cdr -> hdc
lrwxrwxrwx 1 root cdrom 3 2008-10-12 17:08 /dev/cdrom -> hdc
lrwxrwxrwx 1 root cdrom 3 2008-10-12 17:08 /dev/cdrw -> hdc
lrwxrwxrwx 1 root cdrom 3 2008-10-12 17:08 /dev/cdwriter -> hdc

so "mount /dev/cdrom /mnt/cdrom" should work?

But it does not, however if I do :

"mount /dev/hdc /mnt/cdrom" it does work. Huh?

So I have changed the /etc/fstab entry to :

/dev/hdc    /mnt/cdrom  iso9660 defaults,noauto,ro,user 0 0

O.K. so it mounts manually but how do I get the device icon to work, if I put the device icon on the desktop using the configure desktop menu (when right clicking on the desktop), when I right click on the device icon and choose mount it gives the "Feature only available with HAL" message.  If I manually mount the CD and then (left) click on the CD device icon on the desktop it tries to open "media:/cdrom" this should be /mnt/cdrom.  How can I get this to be seamless?



Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #6 on: October 12, 2008, 01:38:13 pm »

If you want it to be seamless you need to use HAL.  That's what HAL Is for. 

VL-Hot offers a mounting system for hot swappable devices (i.e.USB sticks, PCMCIA cards) without constant polling of the hardware so it reduces CPU cycles and improves system performance.  The trade-off is that it can't offer the functionality that HAL does.  It's a decision you have to make:  a seamless KDE GUI with a pretty icon and the same performance hit that every major distro assumes you are willing to take vs. a somewhat more manual system with better performance.  VL offers a choice most distros make for you.

The other alternative, the one VL Light uses to create a mounting icon, forces you to use a different file manager (not Konqueror) to mount a CD but the unmount process is still decidedly manual.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
quoque
Member
*
Posts: 7


« Reply #7 on: October 12, 2008, 01:45:49 pm »

Is there no way to make the icon mount the correct device (what I do manually) and open the correct device in the file manager, without HAL?  I'll use VasmCC to change to HAL and let you know how I get on.
Logged
quoque
Member
*
Posts: 7


« Reply #8 on: October 12, 2008, 02:11:56 pm »

O.K. I changed to HAL (run Vector control center from the settings menu) click on HARDWARE on the left then double click on Mounter on the right and choose HAL then OK, then reboot).

It now works automatically and less confusingly.

Thank you to all who helped.

Please forgive me if I take this opportunity to have a mini rant about the implications of VL-HOT over HAL not being made clear in the installation process, perhaps there should be a neophyte and expert/mature/knows-what-they-are-doing version of the installation process (even a bit more explanation) so that the person making this seemingly random decision realises it is not.

Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #9 on: October 12, 2008, 04:47:14 pm »

If I remember correctly, with VL-hot you can click the devices icon down by to the system tray and then click the entry for the CD to mount it. You'll then get a CD icon on the desktop. Do the reverse to unmount it. No need to use the terminal.
Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #10 on: October 12, 2008, 07:48:42 pm »

ANdy:  That's true on Standard with Xfce.  I don't think it's true for SOHO.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #11 on: October 14, 2008, 11:26:50 am »

I am using 5.9.1 SOHO with vl-hot (obviously, lol) and I can mount my CD/DVD drive with a KDE desktop icon. Just did right-click, "Create new device", etc...
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!