VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [solved]sigh,failed to install lilo when installtion finish  (Read 1948 times)

JSLLZY

  • Member
  • *
  • Posts: 3
[solved]sigh,failed to install lilo when installtion finish
« on: October 13, 2008, 04:24:57 am »

i dowloaded VL5.9-STD-Gold.iso.but install lilo was failed,so now i can not to boot the vector.

i know use grub to boot it.
i must add something to the menu.lst such as:
title linux
root (hd0,x)
kernel /boot/xxxx root=/dev/sdax ro
initrd /boot/xxxx



but i donot know the vmlinuz or initrd,even i can`t explore the linux partion. either use explore2fs.
it cannot display my linux partion!so boringgggg~who can help me!!!
« Last Edit: October 13, 2008, 10:22:08 pm by JSLLZY »
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3235
Re: sigh,failed to install lilo when installtion finish
« Reply #1 on: October 13, 2008, 05:19:43 am »

you can boot it using the install disk. Follow the example given on the screen. The only thing you need to remember is where the root partition is

JSLLZY

  • Member
  • *
  • Posts: 3
Re: sigh,failed to install lilo when installtion finish
« Reply #2 on: October 13, 2008, 08:26:00 am »

yeah,maybe i can only do that,i reinstall the lilo,now i can boot it.
Logged

tomh38

  • Vectorian
  • ****
  • Posts: 913
Re: sigh,failed to install lilo when installtion finish
« Reply #3 on: October 13, 2008, 02:21:03 pm »

I had this same problem once.  I couldn't get Lilo to install to the Master Boot Record.  If you successfully boot into Vector Linux using the install CD (as M0E-lnx suggested) but still can't install Lilo to the Master Boot Record, try installing Lilo on a floppy disk (I'm assuming your computer has a floppy drive - many newer computer's don't).  If you successfully install Lilo to a floppy disk, you will need to go into the BIOS and change the default first boot device to "floppy disk."  Accessing the BIOS will vary from computer to computer, but usually you need to press a specific key.  It is often the DELETE key or the F2 key.  If it's not one of those, and you have access to the manual for your computer, the information you need may be in the manual.

Booting from a floppy will slow your boot time (a little), but it's faster than booting every time from the install disk (which you can still do if installing Lilo to the floppy doesn't work).  If you have older hardware, I think you'll find Vector Linux to your liking.

Tom
Logged
"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991

JSLLZY

  • Member
  • *
  • Posts: 3
Re: sigh,failed to install lilo when installtion finish
« Reply #4 on: October 13, 2008, 10:21:31 pm »

Thank you who helped me.now the problem has solved.
I add this in menu.lst in my windows xp.
title vector
root (hd0,7)
kernel /boot/vmlinuz-2.6.22.14 root=/dev/hda8 ro
initrd /boot/initrd


now i can boot vector use ntloader and gurb4dos not lilo or grub.
Logged