VectorLinux
November 27, 2014, 05:06:45 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: wesnoth + libboost problem  (Read 1231 times)
Ginjeet
Member
*
Posts: 1


« on: October 15, 2008, 03:33:25 am »

Hello there!
I'm having a problem running wesnoth:

"
ginjeet: wesnoth
wesnoth: error while loading shared libraries: libboost_iostreams.so.1.33.1: can not open shared object file: No such file or directory
"

Installed it with slapt-get so I don't think this should occour...

thx 4 your help!
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: October 17, 2008, 08:31:27 am »

Strange. Make sure boost is installed, although it is listed as a dependency for wesnoth, so it should be.

Try reinstalling boost.
Or a different version of boost (if you enable the testing repos, there are two other versions).

Also see if you have libboost_iostreams.so.1.33.1 in your system (in /usr/lib, I'm guessing).
You might just have libboost_iostreams.so. You can try linking it to libboost_iostreams.so.1.33.1

But there's obviously a problem... probably with the boost package.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #2 on: October 17, 2008, 04:32:42 pm »

Right, I've looked at this, and the problem is that wesnoth was compiled against boost 1.33.1.
The most recent boost packages in the repos are 1.34.1 (in extra) and 1.35.1 (in testing), and those packages do not contain the library that wesnoth needs.
Slapt-get gets the most recent version of boost as a dependency, because wesnoth says "boost >= 1.33.1".

Solutions:
Ideally the wesnoth package should be recompiled against the most recent boost version in the repos.
For the time being, if you downgrade to boost-1.33.1 it will work.
You never know if this might break something else, though. It's possible that other packages depend on a more recent version, but I don't know for sure.

So, you can also keep 1.34.1 and do:
Code:
ln -s /usr/lib/libboost_iostreams.so /usr/lib/libboost_iostreams.so.1.33.1

It's ugly, but the game starts just fine.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!