VectorLinux
September 17, 2014, 09:19:24 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: OpenOffice.org 3.0  (Read 3016 times)
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« on: October 12, 2008, 04:35:17 pm »

Openoffice.org 3.0 is to be released tomorrow. However, the source is already available. VL 5.9 and 6.0 packages would be greatly appreciated. Thanks!

Source: http://www.mirrorservice.org/sites/ny1.mirror.openoffice.org/stable/3.0.0/

EDIT: Maybe this is a faster mirror: http://openoffice.cs.utah.edu/stable/3.0.0/
« Last Edit: October 12, 2008, 04:39:11 pm by Dweeberkitty » Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
alec
Member
*
Posts: 63


« Reply #1 on: October 13, 2008, 11:38:34 pm »

Me too would like to get my hands on OOo 3.0
Logged
gijii
Member
*
Posts: 28


« Reply #2 on: October 14, 2008, 06:12:35 am »

You can get the Openoffice-autobuilder package from here:

http://www.slacky.eu/index.php?option=com_content&task=view&id=8786&Itemid=65

This package should download, build and install Openoffice.org 3.0 automatically.
It is made for Slackware 12.1. May be it works even for older versions.
Give it a try.


Logged

Vectorlinux Soho 5.8, Kernel 2.6.21-ck2. AMD Athlon XP 2.4, 1 GB ram, 320 Gb HD
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #3 on: October 14, 2008, 07:57:49 am »

I'd like to see the go-oo version rather than the upstream 3.0 version (go-oo also has a 3.0 version)

The go-oo version is enhanced more than the upstream OOo

see http://www.go-oo.org

Logged

never_stop_learning
Vectorite
***
Posts: 263


WWW
« Reply #4 on: October 19, 2008, 10:58:34 am »

OOO 3.0 is in the VL Testing repository but these is a dependency error: libart_lgpl >= 2.3.20 is required but only libart_lgpl >= 2.3.19 is available in the Vector repositories. I searched for libart_lgpl >= 2.3.20 at Linux packages to no avail.

Will this cause issues if I install OOO 3.0 without libart_lgpl >= 2.3.20?
Logged

Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: October 19, 2008, 11:16:27 am »

OOO 3.0 is in the VL Testing repository but these is a dependency error: libart_lgpl >= 2.3.20 is required but only libart_lgpl >= 2.3.19 is available in the Vector repositories. I searched for libart_lgpl >= 2.3.20 at Linux packages to no avail.

Will this cause issues if I install OOO 3.0 without libart_lgpl >= 2.3.20?

I was just able to install open office 3.0 and there are a lot of dependencies I had to add...

libart_lgpl-2.3.20-i486-1.tlz
libidn-1.5-i486-1.tlz
libmng-1.0.10-i486-1.tlz
libXmu-1.0.4-i486-1.tlz
libXinerama-1.0.3-i486-1.tlz
libXext-1.0.4-i486-1.tlz
lcms-1.17-i486-1.tlz
gamin-0.1.9-i486-1.tlz
acl-2.2.47_1-i486-1.tlz
attr-2.4.41_1-i486-1.tlz

You can find them all by searching the above names as they are writting here at www.filewatcher.com and downloading.

After installing the above list openoffice installed from gslapt without problem.  Seems to be running fine, but I have not done anything more than open something in each application. But so far so good.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #6 on: October 19, 2008, 11:27:19 am »

OOO 3.0 is in the VL Testing repository but these is a dependency error: libart_lgpl >= 2.3.20 is required but only libart_lgpl >= 2.3.19 is available in the Vector repositories. I searched for libart_lgpl >= 2.3.20 at Linux packages to no avail.

Will this cause issues if I install OOO 3.0 without libart_lgpl >= 2.3.20?
You dont need to add anything this package works without the deps and will be fixed in repo asap
Logged
never_stop_learning
Vectorite
***
Posts: 263


WWW
« Reply #7 on: October 19, 2008, 11:56:41 am »

OOO 3.0 is in the VL Testing repository but these is a dependency error: libart_lgpl >= 2.3.20 is required but only libart_lgpl >= 2.3.19 is available in the Vector repositories. I searched for libart_lgpl >= 2.3.20 at Linux packages to no avail.

Will this cause issues if I install OOO 3.0 without libart_lgpl >= 2.3.20?
You dont need to add anything this package works without the deps and will be fixed in repo asap

Excellent.....! Thank you.....!
Logged

Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #8 on: October 19, 2008, 05:27:48 pm »

go-oo is actually the version in the testing repo, but it is named as openoffice.org-xxx. Do we want to have that package named with the 'G' thing so there is a distinction, this is not the actual OpenOffice from Sun but is a fork of it by Novell? Just a thought.
Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
DrCR
Vectorite
***
Posts: 166


« Reply #9 on: October 30, 2008, 04:54:23 pm »

OOO 3.0 is in the VL Testing repository but these is a dependency error: libart_lgpl >= 2.3.20 is required but only libart_lgpl >= 2.3.19 is available in the Vector repositories. I searched for libart_lgpl >= 2.3.20 at Linux packages to no avail.

Will this cause issues if I install OOO 3.0 without libart_lgpl >= 2.3.20?
You dont need to add anything this package works without the deps and will be fixed in repo asap

root:# slapt-get --search openoffice
bluefish-1.0.7-i586-2vl59 [inst=yes]: bluefish (web development application)
openoffice.org-2.4.0_en_US-i586-1vl59 [inst=no]: OpenOffice.org Office Suite
openoffice.org-3.0.0_en_US-i586-1vl60 [inst=no]: OpenOffice.org Office Suite

root:# slapt-get --install openoffice.org-3.0.0_en_US-i586-1vl60
Reading Package Lists... Done
Excluding openoffice.org, use --ignore-dep to override
The following packages have unmet dependencies:
  openoffice.org: Depends: kdelibs >= 3.5.10
The following packages have been EXCLUDED:
  openoffice.org
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Done


Not sure what repo I'm seeing this OO3.0 package in (don't know of a way to tell), but this one apparently isn't dep-free.

DrCR
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3179



« Reply #10 on: October 31, 2008, 08:24:25 am »

there is a version for vl59 available in the testing repos

Looks to me from that output that you have the veclinux-current repos enabled... that would create a conflict for you here

I would enable the veclinux-5.9/testing and then slapt-get -u
slapt-get --search openoffice
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!