Please support VectorLinux!

Author Topic: CTRL_EVENT_DISCONNECT in rtl8187b  (Read 1751 times)

Neopablo

  • Member
  • *
  • Posts: 8
CTRL_EVENT_DISCONNECT in rtl8187b
« on: October 21, 2008, 05:11:19 am »
Hi! Sorry for my english, non english-speaker!! After giving me a good fight, i finally made my usb rtl8187b wireless card work with ndiswrapper. But i´m having troubles connecting to my network. It´s wpa2, so i use wpa_gui. It detects the network, i put the password, and connects, but disconnect continuosly, like: connect, disconnect, connect, disconnect, with that message: CTRL-EVENT-DISCONNECT: REMOVING KEYS.
  Any clue? Thanks in advance, if somebody needs more information, ask me, i´m sort a newbie in linux :). (I use VL light)

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: CTRL_EVENT_DISCONNECT in rtl8187b
« Reply #1 on: October 21, 2008, 05:57:27 am »
From what I can find try this:

Quote
A temporary workaround for avoiding those annoyning disconnecting sessions is to run wpa_cli:

$ sudo wpa_cli

and issue the command ap_scan 0

> ap_scan 0


It appears you have already used this card before. Here a link to a Howto to make sure
you got all the steps.

http://forums.remote-exploit.org/archive/index.php/t-9377.html

Bigpaws

Neopablo

  • Member
  • *
  • Posts: 8
Re: CTRL_EVENT_DISCONNECT in rtl8187b
« Reply #2 on: October 21, 2008, 10:19:08 am »
Hi Bigpaws!
                I tried running wpa_cli, and commanding ap_scan 0, but i can´t get  wpa_supplicant to even try to connect the network. If i activate ap_scan 1, then it reconnect, but starts to connect/disconnect. I thought of wifi-radar, but i got some troubles compiling it from source, because all of the gtk stuff. Finally, i got it running, but i have an error, saying something about gtk, I´ve found lots of information about that issue, so, i´m working on it. Anyway, I´ll start with wpa_supplicant from scratch. Perhaps i could have some misconfiguration.
Thanks for the reply!!

Pablo

Neopablo

  • Member
  • *
  • Posts: 8
Re: CTRL_EVENT_DISCONNECT in rtl8187b
« Reply #3 on: October 21, 2008, 10:45:19 am »
Well! Got it working, in fact, i'm surfing the web through my Vector  ;o). For my shame, i must say it was a mistyping error in the name of my network. But, the curious thing is that, when i do scan of networks, mine appears, but trying to connect, gives this error of connect, disconnect. Right now i don't care!!! But is something to work on. Thanks everybody, specially Bigpaws.

P.D.: Bigpaws, i don't know if Vector Linux is going to have spanish language support, but if it does, i can give a hand in translating documents. Just in case... ;o). Until my next problem!!

Pablo

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: CTRL_EVENT_DISCONNECT in rtl8187b
« Reply #4 on: October 21, 2008, 01:11:59 pm »
P.D.: Bigpaws, i don't know if Vector Linux is going to have spanish language support, but if it does, i can give a hand in translating documents. Just in case... ;o). Until my next problem!!
Pablo

We're working on translating installer (and maybe vasmCC) to various languages , I've done part of spanish translation, but I'm sure there's more to come. The documents thing is a nice idea, but we would have to be very well organized if we don't want to end with many half translated docs or outdated docs.

Te invito a que te pases un dia por #vectorlinux-es (el canal hermano de #vectorlinux) en freenode.  Bienvenido ;)