VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 080122 gtkam-0.1.5 [VL 6.0]  (Read 1279 times)

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2878
    • The Linux Works
080122 gtkam-0.1.5 [VL 6.0]
« on: October 22, 2008, 12:26:34 am »

vector has packaged gtkam for VL 6.0.

Package: gtkam-0.1.5-i586-1vl6.tlz
MD5: 963f863880287297153ee157da9bba49
Package Size: 613K
Installed Size: 1610K

Sources: http://vectorlinux.osuosl.org/veclinux-current/source/testing/x-apps/gtkam

Code: [Select]
gtkam: gtkam
gtkam: gtkam is the official GTK2 GUI for libgphoto2. Its purpose it to
gtkam: provide a standard client for libgphoto2 aimed at GNOME users.
gtkam: Consider it as a reference implementation for a graphical
gtkam: libgphoto2 client.
gtkam:
gtkam:
gtkam:
gtkam:                 http://www.gphoto.org/proj/gtkam/
gtkam:                            WWW.VECTORLINUX.COM
gtkam: Packager vector

After testing this package, please take a moment and come back to this thread to let us know how it works for you.

« Last Edit: October 22, 2008, 02:10:14 pm by caitlyn »
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080122 gtkam-0.1.5 [VL 6.0]
« Reply #1 on: October 22, 2008, 03:41:05 am »

Works fine here. I'd love to know the secret - I made multiple attempts to compile libexif (the main dependency for gtkam) and failed every time. Still don't know why I couldn't get it to build.

paul.
Logged

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080122 gtkam-0.1.5 [VL 6.0]
« Reply #2 on: October 22, 2008, 01:29:19 pm »

 ??? I just reinstalled VL 6.0 (upgrade to alpha 0.22). And now I have a problem - attempting to reinstall gtkam, I get an unmet dependency for libexif-gtk. Attempting to install it gets me an error. It worked earlier.....

Code: [Select]
t42vl://home/tooth
root:# slapt-get --install gtkam
Reading Package Lists... Done
Excluding gtkam, use --ignore-dep to override
The following packages have unmet dependencies:
  gtkam: Depends:   libexif-gtk >= 0.3.5
The following packages have been EXCLUDED:
  gtkam
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done
t42vl://home/tooth
root:# slapt-get --install libexif-gtk
Reading Package Lists... Done
No such package: libexif-gtk
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I can get round the problem, since I have libexif-gtk in local cache, but I'm wondering why it has vanished from the repo?

paul.
Logged

caitlyn

  • Moderator
  • Vectorian
  • *****
  • Posts: 2878
    • The Linux Works
Re: 080122 gtkam-0.1.5 [VL 6.0]
« Reply #3 on: October 22, 2008, 02:00:02 pm »

I have had a problem with 6.0 Light alpha 0.9 where even though the /etc/slapt-get/slapt-getrc file points to the veclinux-current repository (6.0 repository) it pulls packages from 5.9.  I've also had problems where slapt-get/gslapt sometimes finds the gsb part of the 6.0 repository and sometimes it doesn't.  The problem appears to be with slapt-get and gslapt and I suspect that's what you're running into.  I seriously doubt any libraries have been removed from the repo.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

toothandnail

  • Moderator
  • Vectorian
  • *****
  • Posts: 2527
Re: 080122 gtkam-0.1.5 [VL 6.0]
« Reply #4 on: October 22, 2008, 02:08:26 pm »

I have had a problem with 6.0 Light alpha 0.9 where even though the /etc/slapt-get/slapt-getrc file points to the veclinux-current repository (6.0 repository) it pulls packages from 5.9.  I've also had problems where slapt-get/gslapt sometimes finds the gsb part of the 6.0 repository and sometimes it doesn't.  The problem appears to be with slapt-get and gslapt and I suspect that's what you're running into.  I seriously doubt any libraries have been removed from the repo.

There's something a bit strange about this one. The package that I got earlier in the day is as below:

libexif-gtk-0.3.5-i586-2gsb.tlz

so it seems to be a 6.0, but from the Gnome Standard Build branch. Odd also, it downloaded to /packages/libraries, instead of the more normal /packages/libs. I've checked, and I do have the gsb repo enabled, so I'm not at all sure what is going on with that one.

paul.
Logged