Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: ATI mach64?  (Read 5652 times)


  • Member
  • *
  • Posts: 19
ATI mach64?
« on: August 23, 2008, 04:24:38 am »

Ive read several places around the web about the mach64 driver not being maintained anymore....and that due to insecurities isnt supported in newer this true?
Ive cant seem to get the mach64 kernel to load ....ive downloaded the source and it compiles fine dri installs perfectly but the mach64 driver wont...again ive tried all the tips and hacks around the web to no avail ....I even tried the Xmach64 server .... I have an ati rage 3d pro  (which I know is never going to play Americas Army :)
but I would at least like to be able to get some acceleration.

lol....or should I just come off a few bucks and get a decent card?

p.s. thanx
« Last Edit: August 23, 2008, 04:27:27 am by deepsix »


  • Vectorian
  • ****
  • Posts: 1889
Re: ATI mach64?
« Reply #1 on: August 23, 2008, 05:43:07 am »

Mach64 is a 2 meg card. That will not play the game either. Below
are the specs from the site.

The General System Requirements for America's Army are:

* Video card supporting Pixel Shader 2.0 or later with at least 128MB RAM.

So getting another card would be better.


The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1559
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: ATI mach64?
« Reply #2 on: August 23, 2008, 06:20:45 am »

I have an ati rage 3d pro
My old laptop has one of those too, don't expect to get 3d acceleration from it.
lol....or should I just come off a few bucks and get a decent card?
I'd go with that one.
Most music on my soundcloud page was arranged in programs running on VL.


  • Administrator
  • Vectorian
  • *****
  • Posts: 4404
Re: ATI mach64?
« Reply #3 on: August 23, 2008, 11:11:54 am »

30 bucks buys you a GeForce at newegg. Good bang for the buck.


  • Member
  • *
  • Posts: 2
Re: ATI mach64?
« Reply #4 on: October 26, 2008, 06:56:53 pm »

That's great guys...for desktop users.

I have an old Compaq Prosignia 150 notebook laptop here with integrated ATI 3D Rage Pro (mach64) graphics and would really like to get hardware acceleration working. (Many of the games are completely unplayable in the system's current state.)

That said, take a look at this thread:
It's for Fedora 8 & 9.

Is there anywhere I can pick up a "xorg-x11-drv-ati" package for VectorLinux that contains the mach64.ko and files?

Thanks very much for any input you can offer.


  • Member
  • *
  • Posts: 2
ATI mach64 driver HOWTO install
« Reply #5 on: October 27, 2008, 09:42:51 am »

Okay, for anyone else looking for this, here you go.

To install the Mach64 driver on VectorLinux (5.9 at least):

If you didn't install the dev and/or kernel source packages during install, do the following as root:
Code: [Select]
slapt-get --install binutils make gcc kernel-src
cd /usr/src/linux-`uname -r`/include
ln -s asm-<your architecture> asm (e.g. ln -s asm-i386 asm)

Continuing as root:
Code: [Select]
slapt-get --install git
cd ~ (or some other working directory)
git clone git://
cd drm/linux-core
make mach64.o
cp *.ko /lib/modules/`uname -r`/kernel/drivers/char/drm/
depmod -a
Then reboot.

To clean up unneeded stuff:
Code: [Select]
slapt-get --remove binutils make kernel-src git
cd ~  (or whatever working directory you used above)
rm -r drm/

That's it. Make sure your system is set to 16-bit color for best performance. E.g. in your /etc/X11/xorg.conf file:
Code: [Select]
Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
        DefaultDepth    16
        SubSection "Display"
            Depth       16
            Modes           "1024x768"

Apparently my system doesn't support blending, as I get "illegal instruction" on the console when an application tries to use it. So if you see this problem, disable that when you start an application (e.g. chromium -nb)