VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: hald: failed (VL5.9 SOHO) -- SOLVED  (Read 6713 times)

kukibl

  • Guest
Re: hald: failed (VL5.9 SOHO)
« Reply #15 on: December 01, 2008, 11:28:00 am »

I am curious - can someone else reproduce same problem? The thing is that newer glib2 package is located in /patches repository so I guess it would be safe to upgrade. Also it is automatically downloaded as dependency for some packages (in example - pidgin 2.5.2). I would like to know is it mistake made by packager/developer or is it is something specific for my machine and configuration. :-\

Thank you!
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: hald: failed (VL5.9 SOHO)
« Reply #16 on: December 01, 2008, 03:40:27 pm »

IMO glib2 should not be updated between releases.
There are too many things that can fail if it is.
There are newer versions of some packages that do require new glib2 versions.
If you need one of them I would recommend upgrading VL versions first.
the other option is to find everything that fails and rebuild all of them.
I will move glib2 out of the patches repo and into the unstable repo where it belongs.

Uelsk8s
Logged

kukibl

  • Guest
Re: hald: failed (VL5.9 SOHO)
« Reply #17 on: December 02, 2008, 04:03:27 am »

Ok, I understand. There is no need for any special upgrade. I just saw that pidgin 2.5.2 is available in VL repo and wanted to upgrade, but it required newer glib2 (which caused all this problem with hal). That is why I "reported" that glib2 is in /patches repo, but I don't see any special reason for that when you count in that it makes such a mess on system.

Thank you!
Logged

LLL

  • Global Moderator
  • Vectorite
  • *****
  • Posts: 263
  • The sun is shining...
Re: hald: failed (VL5.9 SOHO)
« Reply #18 on: December 07, 2008, 07:19:27 am »

Downgrading versions worked for me, too - HAL is working as expected.

Thanks!

LLL
Logged
Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)

LLL

  • Global Moderator
  • Vectorite
  • *****
  • Posts: 263
  • The sun is shining...
Re: hald: failed (VL5.9 SOHO) -- SOLVED
« Reply #19 on: December 08, 2008, 07:45:24 pm »

...but now Inkscape won't work - it must have been the culprit in the glib update...

Quote
inkscape 0.46 should require glib2 = 2.16 because older glib2 versions do not
provide the symbol g_dpgettext which is required by inkscape.

If glib2 is below 2.16, inkscape will crash on startup with
"inkscape: symbol lookup error: inkscape: undefined symbol: g_dpgettext"
From: http://lists.opensuse.org/opensuse-bugs/2008-04/msg00922.html

Downgrading Inkscape to 0.45 should bring it back to life, minus the new features in 0.46.
Logged
Lost & Lovin' Linux...living on:
VectorLinux 6.0 with XFCE on Thinkpad T43p (2.13 GHz | 2GB | 60GB)
Pages: 1 [2]