VectorLinux
April 16, 2014, 07:44:52 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3
  Print  
Author Topic: updates to 5.9  (Read 6315 times)
overthere
Vectorian
****
Posts: 1218



« on: October 24, 2008, 06:07:17 pm »

Hi
I decided to update my 5.9 std install.
I already added the novmsplice fix(sp)
I downloaded the 2.6.26.6 kernel and modules and installed via installpkg then added to lilo.
I then rebooted and chose the 2.6.26.6 option

during boot.. modules post.. FAILED

the system boots and is useable so far...

what do I need to do to update kernal correctly?

May I assume that the newer kernel includes kernel patches so I then only need to install newer software and/or there patches? this via gslapt with patches and extras loaded? click update?

sorry..do I have this all wrong.
Logged

Everything Is Relative
bigpaws
Vectorian
****
Posts: 1831


« Reply #1 on: October 24, 2008, 07:20:43 pm »

Did you as root update lilo by using as root:

lilo

Bigpaws
Logged
overthere
Vectorian
****
Posts: 1218



« Reply #2 on: October 24, 2008, 08:14:17 pm »

sooo...I should not be useing that kernel?...no updates required? wait for 6.0 final?

root:# lilo
Warning: LBA32 addressing assumed
Added linux *
Added linux-tui
Added linux-gui
Added 2.6.22.19
Added 2.6.26.6
One warning was issued.

Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #3 on: October 24, 2008, 09:17:07 pm »

I'm using the 2.6.26.6 kernel on my 5.9 Light install without problem.  I had to add madwifi to support my older Atheros chipset wireless card, but that's to be expected with any 2.6.25 or newer kernel.  Other than that it's been problem free with no failures on my system.

Which module fails to load?  Can you post the actual error message?  Is the error causing any actual problems for you when you boot into 5.8 with the new kernel (last choice in your lilo menu)?
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
overthere
Vectorian
****
Posts: 1218



« Reply #4 on: October 25, 2008, 06:35:07 am »

Hi caitlyn
I came in at 5.9 and downloaded when final came out so do not have 5.8 to test the kernel on....

The boot splash is off so during boot you see the text fly by..at loading modules.....failed instead of OK and I also see cacheing fonts.....failed rather than OK...

the system boots to login and appears as usual...I simple do not understand the modules thing and have not run all programs yet to see if all is well..

naturally all I desire is to keep the system up to date and secure

I to date have not really done very much in this regard as 1 I did not know I had to and 2 I was attempting to familiarize myself with the  basics of running the system. with limited time I now know basically how to add a program and customize the various window managers.

I see there are several posts on newer kernals and recompileing...I for education downloaded the 2.6.22.19 src...installed via installpkg cd to the directory and make&&makemodules_install then cp to boot and add to lilo...that took several hours but seems to work as well but also has the loading modules...failed. but I think I recompiled for no reason and it went well?

I want to learn more about that but more importantly want to update the system correctly and use it.

thanks if you get what I mean...I just want to understand the modules purpose and why they fail to load..and do  kernal patches get added to newer kernals so I do not need to patch it so much during an update session.

also how do I update the browsers etc. do I just install the new over the old in 5.9std...in light I did boldly just install opera and it installed to home but did kept all the links and is fine but not correct

how do I update correctly...I can eaisly just pound away and mess everything up and reinstall but I thought it may be better to read the manual..or ask...I have been reading and ended up recompileing a kernal for no reason...fun as it was I have no idea what I am actually doing and need better understanding

anyway thanks
« Last Edit: October 25, 2008, 06:44:21 am by overthere » Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #5 on: October 25, 2008, 12:04:22 pm »

5.8 was a typo.  It should have read 5.9.  I was updating the 5.8 repos when I wrote that Sad

The 2.6.26.6 kernel does not fix any security issues so that kernel isn't mandatory.  What it does is add support for newer hardware and fix some bugs.  There is also a 2.6.25.7 kernel that you could use.

The failure message on the modules means that *one* or more kernel modules didn't load.  It doesn't mean that all modules failed.  Did you have the novmsplice patch installed on your original 2.6.22.19 kernel?  If so that is what's causing the error.  It isn't needed and doesn't work with the newer kernel.  Comment out the line referring to it in /etc/rc.d/modules (done as root in your favorite text editor) and that error will go away. 

If it isn't novmsplice then you can find out what is causing the error by examining your logs.  Find your last boot sequence in /var/log/messages and you'll be able to see which module isn't loading and if it's actually important or not.  It could be your configuration is trying to load a module for hardware you simply don't have.

The font caching failure is an entirely different issue not related to the kernel.  Do you have access to all your installed fonts in your favorite word processor?  Have you installed the fontfix patch?  Check in gslapt to see if you have a package called fontfix installed.  If not, well... it's in patches for a reason.  Make sure the patches repository is enabled in gslapt.  You can check that by clicking on Edit->Preferences and choosing the Sources tab.  You should always have packages, extra, and patches checked off.  As a general rule you should not have testing checked unless you want to test a specific new package.

Doing updates:  There are two methods.  One if to upgrade specific programs where you want a security patch, a bugfix, or a new feature.  You just do an install with either slapt-get or gslapt and the upgrading part (removing the old, installing the new) is handled pretty much automatically.  The only exception to this are kernel packages.  They should NEVER be upgraded.  You did it the right way already--install the new alongside the old.  That way if you have a problem with the new you can boot into the old and go back to what you know works on your system.

The second option is a system-wide upgrade.  This is what distros like Ubuntu and Fedora recommend.  A system-wide upgrade replaces all packages with the latest and greatest version for the release of VL you are running.  It will not replace 5.9 packages with 6.0 packages. The advantage of a system-wide upgrade are that you know your system will have every possible security vulnerability patched and any known significant bugs will be fixed.  The disadvantage is that you may get upgrades you don't really need for your system and the more you change the greater risk of breakage.  I have done system upgrades with VL religiously and I have yet to break anything in 5.9 but, as always, YMMV.  I'll also add that I'm running Light rather than Standard at the moment.

OK, if you decide to do a system upgrade that is only available at the command line.  You MUST have patches enabled before you try this.  As root you type:

slapt-get --update
slapt-get --upgrade

It takes a while but everything from Firefox to AbiWord to WiFi-Radar as well as more core things like X and CUPS (printing) will all go to newer versions.

There is no "correct" method.  The method you choose depends on your needs and how you want to manage the system.  In Linux, and in UNIX as well, there are always several different ways to get things done.

I hope I haven't made things as clear as mud Sad

Regards,
Cait
« Last Edit: October 25, 2008, 12:09:36 pm by caitlyn » Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
overthere
Vectorian
****
Posts: 1218



« Reply #6 on: October 25, 2008, 06:30:05 pm »

Hi
A quick thanks for this excellent info..I am off now to execute

I only added novmsplice to the std..I assumed it was already included in 2.6.22.19 and this 2.6.26.6 one and thought it better to replace the kernel than to patch it if possible but was no really sure.

will check the logs and add the font fix and then decide on the rest..choice matters..when you know what the choices are.

thanks again
cheers
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1218



« Reply #7 on: October 25, 2008, 10:03:53 pm »

thanks again caitlyn...I commented out the novmsplice and no longer get the error when booting the two added kernels, I would need to un-comment if reverting to the original boot?

also.. I added the font fix and still get the error on all boot options. I am not sure how many fonts I had but there are 60 odd fonts listed in abi at the moment. should the fix have posted cacheing font...OK or just added fonts?

I see there are several patches listed for which I am not sure I have the program so I decided to add those that seemed to apply for now.
thanks
Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #8 on: October 25, 2008, 10:56:51 pm »

thanks again caitlyn...I commented out the novmsplice and no longer get the error when booting the two added kernels, I would need to un-comment if reverting to the original boot?

Exactly correct.  You'd have an unpatched (and vulnerable) kernel.  There's no reason to use the older kernel, though, if the newest one works.  Just make that your default.

Quote
also.. I added the font fix and still get the error on all boot options. I am not sure how many fonts I had but there are 60 odd fonts listed in abi at the moment. should the fix have posted cacheing font...OK or just added fonts?

The fontfix patch enables fonts which were installed on your system by VL 5.9 but disabled.  It also re-caches the fonts. I didn't know if it would solve the problem or not.  If your fonts are available and working properly I wouldn't worry to much about the font cache error.

[font]I see there are several patches listed for which I am not sure I have the program so I decided to add those that seemed to apply for now.[/font]

Anytime a package included on the original iso is updated for any reason it goes into patches.  That usually means either security patches or bug fixes.  If you don't have a given package installed there is no reason to grab anything out of patches.  There are also packages for madwifi and ndiswrapper which are left out of some of the newer kernels.  Does it make sense now?

HTH,
Cait



[/quote]
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
overthere
Vectorian
****
Posts: 1218



« Reply #9 on: October 26, 2008, 11:17:22 am »

Oh...I can make the newer kernel default, so it boots automatically without deleteing the others? how do you change the order?

I will try to add a font later, there are 60 or more and It is not an issue at the moment. thanks

I have patches loaded in gslapt and still working on it, feeling more confident.. thanks very much.
Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #10 on: October 26, 2008, 12:30:32 pm »

Oh...I can make the newer kernel default, so it boots automatically without deleteing the others? how do you change the order?

As root you need to edit your /etc/lilo.conf file.  Every entry will have a label.  It will say something like:

label = linux

or

label = vector-hda5

Towards the top of the file there is a line that defines the default.  Right now it probably says:

default = linux

Change linux to the label of the entry you want to be the default.  Save your work and then run the following:

lilo -v

That will rewrite your MBR and the default will be changed.  If you made an error (i.e.: typed an invalid label, invalid sytax) it will report the errors and won't write your MBR.

As far as changing the order you simply move the blocks of code around and then run lilo -v.  The order they appear in when you look at the lilo.conf file is exactly the same as the order in the menu when you boot up.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
overthere
Vectorian
****
Posts: 1218



« Reply #11 on: October 26, 2008, 06:15:01 pm »

Caitlyn
thank you for your patience and insight

The new kernel auto boots and the browsers are updated along with other programs...I will have to use the system to know if any issue exists. At the moment I am confident I have updated the system and may apply this understanding to future updates of it

cheers
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1218



« Reply #12 on: October 27, 2008, 03:27:15 pm »

note- I offer the following in the event it is of interest.

 I updated my browsers and xinelib along with other patches of interest via gslapt with patches loaded, for security or just to update, I had help as above..thanks again
 
afterward I decided to add the remaining patches available for a more complete update

I found the following patches had issue

icon-naming utility--depends- perl-xml-simple & writer-2.18
scribus               --depends- cups-1.3.6
vpackager           --depends- cmake-2.4.6
vasmcc              --downgrade
libgnomeprint      --downgrade
libmad                --downgrade

these patches downloaded but gave a packagetool returns error message after download completed
ruby
hplip
nano
pcre
netshmp
pidgen
xarchive

gimp and sane gave varying depends warnings but seem to have installed,gimp, cups-1.3.6 and gnome-vfs. I installed gimp then sane and bypassed gnome vfs warning

the rest of the list installed without issue.

I seen no harm in attempting the additional updates as I may use some of these programs time or nessessity permitting and may prefer them updated

perhaps these issues have been already covered, I am sorry I have not been able to read all the threads. nor do I understand the depends functionality of the gslapt packagemanager.

I think the gnome-vfs was covered and I passed the warnings and installed, I think the downgrades at least vasmcc is a typo and may be installed via testing?

there may be other things more important at the moment so I am not asking for help to get these installed, just offering my recent experience

If it is of value then...
cheers
Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #13 on: October 27, 2008, 05:04:41 pm »

You clearly tried to do these piecemeal rather than by the method I suggested.  If you had simply done a:

slapt-get --update
slapt-get --upgrade

everything should have resolved itself.  For example, you ran into a cups dependency requiring cups > 1,3,6 but 1.3.7 is in the repository so that shouldn't have been an issue.

I don't understand the downgrade messages at all.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
overthere
Vectorian
****
Posts: 1218



« Reply #14 on: October 27, 2008, 06:22:00 pm »

well caitlyn you suggested more than one option and I feel that a system wide update/upgrade is great after a freash install. I chose to select a few via gslapt with patches loaded only and had no issue and am happy to have updated browsers etc.

however someone may want to use the same method for just vasm and scribus or ruby and libmad, who knows...I had success with what I wanted, and then over several session, attempted to do them all as a test of gslapt to get to know it better...I thought the result may be of value.

the downgrade for vasm was I think covered in another thread I read somewhere...the package being replaced was named incorrectly but the package is fine as is the new, but I do not know if that is the case for the others..I think one may install via testing or something...also as is known the gnome-vfs warning can be overlooked..at least in these cases

the cups error may be due to extras and packages not being loaded but I could not see the patches list with them added. maby if one installed cups 1.3.7 or 1.3.6 if it is in extra then did the patch it would solve..

anyway.. I should know better than to try to be helpfull..

.MANY thanks for helping me update the kernel and browsers I really like this system.
Logged

Everything Is Relative
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!