VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: "Could not find install media" - installing from a PCMCIA CDROM drive  (Read 4834 times)

seileef

  • Member
  • *
  • Posts: 4

Hi, I'm trying to install VL Light 5.9 on a Vaio PCG-505V (an old machine--Pentium I, 300 MHz, 4.3 GB, etc) from an external PCMCIA CDROM drive.  On the setup screen, after choosing "find the media (HD/CDROM) and start the installation", I get "ERROR ERROR! I could not find the install media on the hard disk or the CDROM as well", followed by a little more text about the different options of installing. 

I tried probedisk, but it only listed the hard disk (no CDROM).  dmesg listed a whole lot of ACPI errors, and nothing about a drive other than the hard disk.  I'm very new to linux installs, and I couldn't find much related info on this, so I'm not sure what to try next.  Any ideas?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #1 on: October 29, 2008, 09:43:49 am »

I suspect the PCMCIA drive is not supported. A lot of those old laptops had proprietary controllers for external devices.

You still have several options. Some questions:
Is there a working OS on the computer right now (w98 or similar)?
Have you tried running a LiveCD?
Does it have a floppy drive that you can boot from?
Logged

seileef

  • Member
  • *
  • Posts: 4
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #2 on: October 29, 2008, 09:57:33 am »

Ah, rats.  I currently have an installation of Debian (etch) on there.  What would be the route to go with that?  I'm not terribly familiar with partitioning, but because of the limited hard disk space, I'd like to dedicate as much of the drive to the primary OS (hopefully VL) as possible.

I found some LiveCDs of VL, but none of VL Light--do you know where one might be (if that would be preferable to the above route, that is)?  The machine doesn't have a floppy drive.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #3 on: October 29, 2008, 10:57:12 am »

Try this one: http://vectorlinux.osuosl.org/veclinux-5.9/iso-release/VL5.9-Light-LIVE-B1.iso
It does have a hard drive installer, but it may need a little hand-holding. First of all just see if it runs okay.
Logged

seileef

  • Member
  • *
  • Posts: 4
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #4 on: October 29, 2008, 05:53:23 pm »

OK, after booting off the LiveCD, I get some initialization lines, but then there's a fatal error:

Fatal error occured - VLIGHT data not found.
You are maybe using an unsupported boot device (eg. SCSI or old PCMCIA).
Workaround: Copy the directory VLIGHT from your boot device to an IDE/SATA disk, eg. to /mnt/hda1/VLIGHT or C:\VLIGHT. Then try to boot again.

Should I go ahead and try that workaround? 

I'm not sure if it'd be useful or not, but I should mention that the machine does have a USB port, which works fine with the current Debian install I have (in case a thumb drive would be useful for anything).  And, you might've already guessed this, but there's no ethernet port on the machine.  Thanks for all the help with this, by the way.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #5 on: October 29, 2008, 07:17:25 pm »

Allright, we're narrowing down the options here then.

Since the box is already running Linux, you can use the "hosted install" procedure, which involves copying the ISO to the hard drive and installing from within Debian. You probably need to re-partition and/or re-size a partition on the drive to make room for VL, it will need at least 2 GB.

How did you get Debian on there in the first place?
Are you planning on keeping Debian and dual boot?

Logged

seileef

  • Member
  • *
  • Posts: 4
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #6 on: October 29, 2008, 09:27:39 pm »

Cool, sounds good.  I wouldn't really have much use for Debian after this, so I'd ideally like to dedicate the entire hard drive to VL once this is finished. 

A Google search returned a few different ways to partition a drive while keeping the original OS intact--do you have a recommendation of the best way for a bit of a newbie to do it?  I installed Debian installed off of the CDROM drive--it was over a year ago, and I remember that there were a few small hiccups, but I forget exactly what they were.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4108
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #7 on: October 29, 2008, 10:15:31 pm »

As far as I know, the partition that is being re-sized must be unmounted. In other words, you can not do it from within Debian on your machine. If you can get something like Gparted Magic to run off the cd-rom drive, it has a very nice gui tool for doing so.

Another option is to take the hard drive out of machine, connect it to another one and do the operation on the host OS.
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: "Could not find install media" - installing from a PCMCIA CDROM drive
« Reply #8 on: October 29, 2008, 10:24:00 pm »

I've used the hosted install (vinstall-cd script) with a PCMCIA CD-ROM drive on a Toshiba Libretto SS1010.  It works well.  If you need a step-by-step let us know.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1