VectorLinux
April 23, 2014, 04:30:54 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: can't install nor compile codeblocks  (Read 3154 times)
JHAx86
Member
*
Posts: 22



« on: November 14, 2008, 09:45:12 am »

Hi all,

I trying to install codebloks in VectorLinux 5.9-Standard, i have it installed in a PII with 192 MB of RAM. First of all, as I was unable to find a compatible package I downloaded the source code but i couldn't compile it due to a missing library (wxWidgets). So I downloaded the source for wxWidgets but couldn't compile due to a compiler error, so I updated the compiler with the gcc and g++ packages from slackware, with this I Could compile wxWidget and install it but when I tried to compile codeblocks the compiler said "Segmentation Fault" and that this is a bug to report.

As I am unable to compile codeblocks I downloaded the rpm for suse and convert to tgz with rpm2tgz. This way I installed codeblocks but can't launch it as some libraries are missed:

Can somebody tell me where to find libxcb-render-util.so.0?

Thanks for read.
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: November 14, 2008, 11:01:25 am »

I just tried compiling codebloks from source and it went with no problems. Installs and runs fine.
The wxwidgets package is called wxgtk in the repository.
There might be other deps, but if I could do it, it means everything is in the repository.
Give it another try, with the stock gcc and g++ from VL.
Logged
sparkyhall
Vectorite
***
Posts: 118


« Reply #2 on: November 14, 2008, 01:55:47 pm »

Codeblocks 8.02 is in the repositories.....You might have to enable the testing repo, I've used it on occasion over the last couple of months and had no problems.

Chris
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #3 on: November 14, 2008, 03:44:56 pm »

Quote
Codeblocks 8.02 is in the repositories....

There you go... Even easier, just go to gslapt/slapt-get and install.
Logged
JHAx86
Member
*
Posts: 22



« Reply #4 on: November 22, 2008, 01:41:18 pm »

Hello and thanks for the answers,

I cannot use slapt-get because my Vector Linux machine has not internet connections (and this will remain for a while). But once I'd read here that wxWidget and CB exists in the repo I looked for it manually and downloaded to a cd, then installed. No problem, CB works marvelous now I can start to port to linux my projects.

The reansom CB can't be compiled in my machine appears to be in the hardware. Another people from another forums were getting the same "segmentation error" when trying to compile big projects in old machines. Anyway, for now CB works as expected.

Thanks again, good bye.
« Last Edit: November 28, 2008, 10:34:43 am by JHAx86 » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #5 on: December 08, 2008, 07:10:10 pm »

The codeblocks package seems to have been built without -with-contrib-plugins=all, so there is no wxsmith (gui designer) plugin among others.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!