Please support VectorLinux!

Author Topic: Getting the 5.9 SOHO KDE to "speak" my native tounge  (Read 2381 times)

nj_jak

  • Member
  • *
  • Posts: 47
Getting the 5.9 SOHO KDE to "speak" my native tounge
« on: October 28, 2008, 04:17:55 am »
Hi all Vectorians !

I am really enjoying this great distro, and I will now try to convince family and friends just how great it is. I feel pretty fluent in English myself,  but parts of my family would be far easier to convince using Vector, if I could present them with a KDE speaking Danish.

Is the task ahead of me downloading language files from KDE.org and recompile the whole thing?

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #1 on: October 28, 2008, 09:51:14 am »
Actually we should have the Danish i18n package for KDE and the i10n package for koffice in the repository.  You can install them with gslapt or slapt-get.  If you want your system to run everything it can in Danish by default (not just KDE apps) you can edit (as root) /etc/profile.d/lang.sh.  You'll see a line that says

export LANG=en_US

change it to (assuming Denmark is your location)

export LANG=da_DA.utf8

under that add one additional line:

export LC_ALL=da.DA.utf8

At next boot your system will be in Danish provided Danish translations exist for the apps you are running.

We also have the Danish language packs for Firefox, Thunderbird, and Sunbird in the repository and the aspell-da dictionary.

HTH,
Cait
(who does not speak Danish)
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

nj_jak

  • Member
  • *
  • Posts: 47
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #2 on: October 30, 2008, 12:47:14 am »
Thanks Cait,

but I am afraid, that I did not get any further.
I only see i18n's in the repository for the modren flavours of latin: french, spanish, portuguese and italian

Using gslapt shows me, that those languages are already installed (I've installed everything from deluxe disk 2)

So maybe I should file a new package request - or become a packager for danish translations myself.

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #3 on: October 30, 2008, 10:29:16 am »
We actually did have a full set of translations in the repository at one point.  I have Hebrew installed on my system.  We did have a problem sometime earlier this year (before I got involved in maintaining the repositories) where some packages went missing.  Now I know that includes most of the kde i18n packages.  I'll check with the developers and see if anyone can recover any of this.

Let me look into this.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

nj_jak

  • Member
  • *
  • Posts: 47
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #4 on: October 30, 2008, 12:02:26 pm »
Thanks - looking forward....

Earlier today I was browsing through the repository, and found a lot of i18n packages under 5.8 SOHO, so maybe I will try reinstalling 5.8 SOHO on my old laptop (IBM Thinkpad T22/P3-900/512MB RAM) and try to install the danish language files there.

In my effort to promote Linux to the non-English speaking part of the family, I have tried to install Mandriva One 2009, but that had only danish in the install process, and I've tried Ubuntu 8.04 which was OK on the language part, but did not meet my "everything working out of the box" requirement. The former two were on single CD's, so I thought trying openSUSE (4.3GB) on a DVD would be sufficient, but that one wouldn't install on my old laptop.

So despite these unfaithful attempts to use other distros I have decided to stick with the best and try promoting Vector :)

/NJ

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #5 on: October 30, 2008, 03:16:47 pm »
It isn't difficult at all tobuild the i18n packages from source.  I no longer have VL 5.9.1 SOHO on my box -- I needed the partition for more VL 6 testing, otherwise I'd do it for you.  Consider downloading the source from kde.org and take a look at their instructions and our package building how-to.  You might decide that this is easy enough.  I do NOT recommend downgrading to 5.8.  It's almost two years old and support is coming to an end.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #6 on: October 30, 2008, 03:23:05 pm »
johnB's kde-3.5.10 for soho is here: http://uelsk8s.no-ip.org/johnb316/kde-3.5.10/kde-i18n/
I guess he didnt have time to upload it all yet?

nj_jak

  • Member
  • *
  • Posts: 47
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge (SOLVED)
« Reply #7 on: November 03, 2008, 12:42:11 am »
Thank you uelsk8s and caitlyn.

I have now a Danish set up for KDE. Could I have a little hint on where to find the danish FireFox and Thunderbird ?

'Tak for hjælpen' - that's Danish for 'thanks for your help'

/NJ

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #8 on: November 06, 2008, 04:12:26 pm »
Make sure you have the extra and patches repositories enabled in gslapt or in your /etc/slapt-get/slapt-getrc file.  You will first need to upgrade Firefox to v. 3.0.3 which is in patches.

The language packs are in the extra repository.  You'll find packages like:

firefox-langpack-da
thunderbird-langpck-da

There are also language packs for Sunbird if you use that.
« Last Edit: November 06, 2008, 04:16:04 pm by caitlyn »
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

vovane

  • Member
  • *
  • Posts: 50
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #9 on: November 16, 2008, 01:18:48 pm »
caitlyn,thanks you very much,thanks to your instructions i've been finally able to set my VL in russian:) I digged all over russian internet and then a good thought came to my mind - "Look at the vl forum,you lamer!".And after about 3 minutes of walking through the forum,i found this topic.I do not use kde,so i didn't install any additional packages,it started to work OK after reboot,as you said.Thanks again!But there's a little problem - russian filenames are still dont look russian :) Is there a way to change codepage for filenames?I'd appreciate if it will not require rebooting,since i'm not sure what codepage files use.Well,at least filenames at win partition look fine,thanks anyway :)
« Last Edit: November 16, 2008, 01:26:47 pm by vovane »

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #10 on: November 16, 2008, 01:40:39 pm »
Codepage is a DOS/Windows term, so it doesn't fit. 

Are the filenames not showing up correctly in X (GUI) or on the terminal and in terminal windows?  It's going to be a matter of setting the correct font.

Also, I did forget one variable in my description above.  Set LINGUAS as well as LANG, LANGUAGE, and LC_ALL.  See if that helps.
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

vovane

  • Member
  • *
  • Posts: 50
Re: Getting the 5.9 SOHO KDE to "speak" my native tounge
« Reply #11 on: November 17, 2008, 10:48:58 am »
I set LINGUAS to ru_RU.KOI8-R,and it's one more ok :) Spasibo za pomosch - thanks for help in russian :) Actually filenames used to be the main problem and thanks to you it works fine.By the way,filenames were incorrect in X(thunar,etc).And when i said codepage,it was too late in Moscow for my brain to work,that's why i said "codepage",the exact word was out of my brain :) It is "charset",right?
« Last Edit: November 18, 2008, 03:47:12 am by vovane »